libcoap 4.3.5
Loading...
Searching...
No Matches
Topics
Here is a list of all topics with brief descriptions:
[detail level 12]
Application APIApplication API Structures, Macros, Typedefs, Enums and Functions
  Application I/O HandlingAPI for Application Input / Output checking
  Asynchronous MessagingAPI for delayed "separate" messages
  Block TransferAPI for handling PDUs using CoAP Block options (RFC7959)
  Cache SupportAPI for Cache-Key and Cache-Entry
  Clock HandlingAPI for internal clock assess
  Context HandlingAPI for handling PDUs using CoAP Contexts
  DTLS SupportAPI for interfacing with DTLS libraries
  Encode / Decode APIAPI for endoding/decoding CoAP options
  Event HandlingAPI for event delivery from lower-layer library functions
  Logging SupportAPI for logging support
  LwIP specific APIAPI for LwIP interface
  OSCORE SupportAPI functions for interfacing with OSCORE (RFC8613)
  Option FiltersAPI for access option filters
  Optional functionalityAPI for determining functionality optionally compiled into libcoap
  PDUAPI for PDUs
  ProxyAPI for Proxies
  Pseudo Random NumbersAPI for generating pseudo random numbers
  Rate ControlAPI for updating transmission parameters for CoAP rate control
  Resource ConfiguratonAPI for setting up resources
  Resource ObservationAPI for interfacing with the observe handling (RFC7641)
  SessionsAPI for CoAP Session access
  String handling supportAPI for handling strings and binary data
  URI Parsing FunctionsAPI for parsing URIs
  WebSockets SupportAPI for interfacing with WebSockets (RFC8323)
Libcoap Internal APILibcoap Internal API Structures, Macros, Typedefs, Enums and Functions
  ASN.1 SupportInternal API for CoAP ASN.1 handling
  Application I/O HandlingInternal API for Application Input / Output checking
  Block TransferInternal API for Block Transfer (RC7959)
  Cache SupportInternal API for Cache-Key and Cache-Entry support
  Context HandlingInternal API for Context Handling
  DTLS SupportInternal API for DTLS Support
  Multi-thread SupportInternal API for Multi-thread Locking Support
  Netif SupportInternal API for Netif Support
  OSCORE CBOR SupportInternal API for interfacing with OSCORE CBOR
  OSCORE COSE SupportInternal API for interfacing with OSCORE COSE
  OSCORE Crypto SupportInternal API for interfacing with Crypto libraries
  OSCORE SupportInternal API for interfacing with OSCORE (RFC8613)
  Observe SubscriptionInternal API for handling CoAP Observe Subscriptions (RFC7641)
  PDUInternal API for PDUs
  Pseudo Random NumbersInternal API for generating pseudo random numbers
  ResourcesInternal API for handling resources
  SessionsInternal API for handling Sessions
  SupportInternal API for handling CoAP proxies
  TCP SupportInternal API for handling CoAP TCP (RFC8323)
  URI SupportInternal API for handling CoAP URIs
  WebSockets SupportInternal API for WebSockets Support (RFC8323)