Introduction

Gtk Development Environment is a development environment written using
the GTK+ widget set. It is not an integrated development environment, it
is only meant to act as a framework for all the programs YOU like to use.

It is a development environment in its simplest way. Why GDE? I always
liked to have a `project explorer' and easy shortcuts for making and running
my programs (an IDE like Visual Studio) in Windows. When I started 
programming with Linux, I had to do with a console and some edit windows.
Then I came up with the idea of making a simple IDE. But why integrated I
thought. There are already good compilers, make programs and nice editors.
That's why I decided to create GDE.

GDE can be used to develop all sorts of applications. From c programs to
web sites. You can easily use your favorite editor, an appropriate
compiler, and so on. This time YOU specify which programs must be used!
In think that is free choice. That's Linux.

GDE is developed by Gertjan Zwartjes (g.zwartjes@student.tue.nl), visit
its home page at www.student.tue.nl/u/g.zwartjes.


Projects

So what is a project? In GDE you can manage your programming works in a 
project. A project contains all the information needed to edit, make,
clean and run a certain program.

First of all it contains files. Source file, header files and so called
root files, which can't be qualified either as a source or a header file.

Second it contains four commands:

 * edit command,
 * make command,
 * clean command, and
 * run command

The edit command is executed whenever you want to edit one of the files in 
your project. This command is executed with a filename as extra argument.
The make command is executed whenever you choose to make your project. And
indeed, the clean and run commands are executed when you clean or run your 
project respectively.

To create GDE itself, I use GDE with the following commands:

 edit command: gvim -geometry 80x23+180+80  
 make command: make all
 clean command: make clean
 run command: gde

I also found GDE come in handy creating a web site. Here `upload.script' is
a file containing a script which uploads all the files in my project to
the web server. `clean.script' is a file which deletes all the files in my
project from the server.

 edit command: gvim -geom 80x23+180+80
 make command: ftp -n < upload.script
 clean command: ftp -n < clean.script
 run command: netscape index.htm

All the commands are executed from GDE's current working directory. The
working directory of GDE is only changed when a project is opened. Then
the current working directory of GDE is set to the directory of the
project file opened. Also when saving your project, GDE changes its
current working directory to the directory where you saved your project.

You can imagine using GDE for all sorts of other projects. Because you
choose the commands not only one programming language is supported, even
non-programming projects can be managed with Gtk Development Environment.


Main Window

This is the bar at the top of your screen (there it is by default). You
can see the name of the file of the current open project in the title bar. 
A star (*) indicates wether you've made changes to the current open project 
or not. The main window also contains the menu bar. The menu bar contains 
five menus. The `File' menu does not need explanation I think. With the 
`View' menu you can show the project explorer and messages window again 
if you hid them.

The `Project' menu is one of the most important menus. You can add files to
your project with `Project->Add File(s)...', which you can edit or remove with
`Project->Edit...' and `Project->Remove'. `Project->Settings...' opens the
settings window, where you can choose the preferences for the current
project.

The make, clean and run commands can be executed via the `Command' menu.
With the `Command->Kill' command you can kill the current running command,
so if you want to cancel a command, use kill.

Choosing `Help->About' will show you a nice informative box about the
author and internet addresses.

Below the menu bar you see the toolbar. The toolbar contains shortcuts
to frequently used menu items. Keeping the mouse pointer on one of the
buttons for a while will pop up a tooltip describing its functionality.


Project Explorer

The project explorer is the window on the left of your screen (by default).
Here you can see a summary of files in your project. There's a directory
`Source Files' for the source files in the current project and a directory 
`Header Files' for header files. The other items in the tree view are root
files (see Projects).

You can easily edit a file using the project explorer. Just double click on
a file and the edit command is executed with the selected file as extra
argument (see Projects and Project Settings about commands).

The project explorer also supports drag and drop. You can drag a file out
of the project explorer onto an editor or such. It has no capabilities of
dropping files on it yet.


Messages Window

This is a neat little window on the bottom of you screen (by default). In
here you'll see informative messages generated by GDE. Also all program
output is redirected to this window.

Tip: If your program needs input (using the console) or you don't want to
use redirected output, use a terminal in your run command.


Project Settings

When you choose project settings, you will get a window with all the different
settings for the current project. With this dialog you can easily edit
the edit, make, clean as well as the run command.

If the `check dates before run' check box is turned on, GDE checks if
the dates of all the files in the current project. If there are files with a
date newer then the previous make, GDE will suggest you to first make
the project, before running. Thus, if you choose to run your project, in
which you made some changes after the last time you made your project,
GDE will pop up a dialog with the suggestion of making your project.


Preferences

When you choose `View->Preferences...' or select the `GDE Preferences' tab
in the settings window you can adjust the settings of GDE. The `Messages
Window' frame contains the three fonts used for displaying text in the
Messages Window. The defaults are the default GTK font for informative text
and `Adobe Courier' (-adobe-courier-medium-r-normal-*-*-120-*-*-m-*-iso8859-1)
for program output and errors.

You can also adjust the recent projects list size and choose whether or
not to save GDE's window positions and sizes on exit. Saving window
information on exit implies it will be loaded whenever you start GDE
again of course!

The option `Open last opened project on startup' tells GDE wether or not to
save filename of the last open project and open this project again on startup.
This is very handy if you tend to work a lot on one specific project. I use
this option very often, because there are times when I am working on GDE only.
So I don't have to go through the whole open project steps (yes, of course,
pressing Ctrl+1 also does the trick, but not having to press a button at all
is much more conveniant (also it was worth the extra lines of code)).


Command Line Options

If you execute GDE with `-h' or `--help' you will get a summary
of options, which will look womething like this:

	Usage: 
		gde [options] [file]

	Options:
		-h, --help			Display command line options and exit
		-v, --version		Display version information and exit

Specifying `file' (optional) as argument will result in GDE opening `file'.
If it does not exist, GDE will create an empty project using `file' as
filename for this new project.


Copyright

Gtk Development Environment Copyright (c) 2000 End of the World Software
