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Preface

1. About Mandriva Linux

Mandriva Linux is a GNU/Linux distribution supported by Mandriva S.A. which was born on the Internet in 1998.
Its main goal was and still is to provide an easy-to-use and friendly GNU/Linux system. Mandriva’s two pillars
are open source and collaborative work.

Note: In April 2005 the Mandrakesoft company changed its name to Mandriva to reflect its merger with Brazil-based
Connectiva. Its core product, Mandrakelinux, became Mandriva Linux.

1.1. Contacting the Mandriva Linux Community

The following are various Internet links pointing you to the most important Mandriva Linux-related sources. If
you wish to know more about the Mandriva company, connect to our web site (http://www.mandriva.com/).
You can also check out the Mandriva Linux distribution web site (http://www.mandriva.com/community/) and
all its derivatives.

Mandriva Expert (http://www.mandrivaexpert.com/) is Mandriva’s support platform. It offers a new expe-
rience based on trust and the pleasure of rewarding others for their contributions.

We also invite you to subscribe to the various mailing lists (http://www.mandriva.com/community/
resources/newsgroups) where the Mandriva Linux community demonstrates its high spirits and keen debates.

Please also remember to connect to our security page (http://www.mandriva.com/security). It gathers all
security-related material about Mandriva Linux distributions. You will find security and bug advisories, as well
as kernel update procedures, the different security-oriented mailing lists which you can join, and Mandriva On-
line (https://www.mandrivaonline.com/). This page is a must for any server administrator or user concerned
about security.

1.2. Join the Club!

Mandriva Club is the place where users meet to help each other out, exchange valuable information about
Mandriva Linux, get informed of the latest Mandriva, Linux and Open Source news. Club subscribers have
privileged access to an even wider array of services.

With your Mandriva ID, you have free access to:

• help (forums, chat, Knowledge Base with tutorials, how-tos, tips and tricks)

• news

• more Mandriva- and community-contributed content

As a Club Member, you have exclusive access to :

• 50.000 software packages, including commercial software, drivers, demos...

• super-fast download servers

• official Mandriva Linux documentation

• Mandriva Online Services - Kiosk, Online, Expert and eTraining

• permanent special discounts at Mandriva Store

• ... and much more !

Mandriva Club is where you get the best Mandriva Linux experience, learning from others, teaching others,
accessing exclusive features and contributing to the development of Mandriva Linux and Free and Open
Source Software in general.
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1.3. Subscribing to Mandriva Online

Mandriva offers a very convenient way to keep your system automatically up-to-date, free of bugs and security
holes. Visit the Mandriva Online Web site (https://www.mandrivaonline.com//) to learn more about this
service.

1.4. Purchasing Mandriva Products

Mandriva Linux users may purchase products on-line through the Mandriva Store (http://store.mandriva.
com/). You will not only find Mandriva Linux software, operating systems and “live” boot CDs (such as Live), but
also special subscription offers, support, third-party software and licenses, documentation, GNU/Linux-related
books, as well as other Mandriva goodies.

1.5. Mandriva Kiosk

Mandriva Kiosk is a service which provides you with a catalog of the most popular software, be it Free or
commercial, for your Mandriva Linux distribution. You’ll find new software for all your needs: from the la-
test version of the OpenOffice.org suite and multimedia applications to the latest KDE and GNOME desktop
environments, games and wallpapers.

It’s very easy to use with its web-based graphical interface, detailed application descriptions and a smooth
one-click install process that will upgrade or extend your system’s functionally in a few minutes. Installing
new software on your Mandriva Linux distribution has never been easier.

Mandriva Linux 2007 Discovery, Powerpack and Powerpack+ users benefit from 30 days of free access to Kiosk
with their free Club trial period. Discover it now at the Kiosk Website (http://kiosk.mandriva.com).

The Mandriva Kiosk service is free to all Mandriva Club members and is also available as a stand-alone service
through an annual subscription. By subscribing to Kiosk, you’re getting:

• access to an easy-to-use web-based catalog of new software - Free and commercial

• packages tested exclusively for Kiosk by Mandriva teams

• packages which seamlessly install on your system

• packages which install with a single mouse click

Enjoy the Kiosk experience!

1.6. Contributing to Mandriva Linux

The skills of the many-talented folks who use Mandriva Linux can be very useful in the making of the Mandriva
Linux system:

• Packaging. A GNU/Linux system is mainly made of programs found on the Internet. These need to be
packaged in order to work together.

• Programming. There are many, many projects directly supported by Mandriva: find the one which most
appeals to you and offer your help to the main developer(s).

• Internationalization. You can help us translate web pages, programs and their respective documentation.

Consult the development projects (http://www.mandriva.com/en/community/contribute/join) page to
learn more about how you can contribute to the evolution of Mandriva Linux.
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2. About this Quick Start Guide

The goal of this manual is to introduce you to the unique features of Mandriva One, and help you use and
administer the system in general. Whether you are a Linux newcomer or an experienced user, you will find
useful information here to completely master your system.

Booting the system. Your product is a “live” CD or DVD, meaning, that you can use it directly without actually
installing it. So, we will assist you with the few startup steps required to bring up your system.

Using the system. If you are new to Linux, you may find yourself like a stranger in a new country. We guide
you in your new environment, and you will soon feel at home.

Taking advantage of your peripherals. Want to use your printer, scanner, or webcam? It’s very easy. Mandriva
Linux supports most devices, and offers great applications to get the most out of them.

Let’s Relax. Mandriva Linux is not only about work! It offers a full range of games for all tastes. We have selected
the nicest ones for you.

Increase your system speed and share it with others. You’ll quickly become a Mandriva Linux fan and find
yourself using the system more often than expected. We show you how to install it on your hard drive for
increased performance, and how to easily make copies of it for your friends and relatives.

3. Starting the MandrivaOne Live CD

MandrivaOne lets you use a fully working Mandriva Linux operating system, with office, Internet and multi-
media tools, even games, off the CD/DVD without the need to install anything on your computer: all the
software runs directly from the CD/DVD.

Use MandrivaOne to try Mandriva Linux before installing it, to do all your work without “interfering” with the
computer’s already installed operating system and files, and to repair a damaged system.

Please refer to “Share and Install your Linux System”, page 53 for more information.

3.1. Booting the CD

Make sure the computer is setup to boot from the CD-ROM drive, insert the MandrivaOne CD and reboot the
computer. Please refer to the computer’s documentation if you need more information on how to set it up to
boot from the CD-ROM.

There are some parameters (language, country, keyboard layout, timezone, etc.) which need to be setup on
each boot; you just have to select your preferences from the suggested ones. Please note the following:

• If you select the Refuse option when you are shown the licensing terms, you are not able to continue using
MandrivaOne, the computer is shut down when you click on Quit.

• After selecting the timezone you are asked if your system’s clock is set to GMT (Greenwich Mean Time). If
you’re unsure please answer No.

3.2. Default User Paswords

The Live distribution is configured so that the default user (guest) and the administrator (root) have no
password. For most operations you won’t be even asked for these passwords, however if it happens, simply
leave it blank.
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Chapter 1. Exploring your New Environment

MandrivaOne brings you an exciting environment to do almost anything you can imagine. In this chapter we
concentrate on Internet usage (Using the Internet, page 5), doing office work (Doing Office Work, page 14), and
multimedia applications (Multimedia, page 21). We detail the configuration of the applications and their basic
usage while leaving you room for exploration.

1.1. Using the Internet

MandrivaOne is an excellent tool to use the Internet. We show you how to manage your email using KMail,
browse the web with Konqueror and chat with your friends and colleagues with Kopete.

1.1.1. Sending and Receiving Emails

Choose Internet→Mail+KMail from the main menu to launch KMail. A configuration wizard appears.

1.1.1.1. Mail Configuration

Figure 1-1. Mail Account Type

Select the account type from the suggested list and advance to the next step. Both IMAP and POP3 accounts
setup are the same.

Figure 1-2. Your Personal Data

Then, you are asked about your name, email address and company name, fill these with your personal data.
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Figure 1-3. Account Credentials

You are then asked for the account credentials: username and password. Your ISP or system administrator
should have provided these along with your email address.

Figure 1-4. Mail Servers

You are finally asked to provide mail server parameters. Again, your ISP or system administrator
should have provided you with the incoming and outgoing mail servers. Outgoing servers are usually
of the smtp.provider.net form. Incoming POP3 servers are usually of the pop.provider.net or
pop3.provider.net forms. Incoming IMAP servers are usually of the imap.provider.net form. The
mail.provider.net form is also common for both incoming and outgoing mail servers.
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1.1.1.2. Mail Client Interface

Folder

List

Toolbar

Message List

Message View 
Pane

Figure 1-5. KMail Client Interface

Toolbar. Where the main action buttons lie. See table 1-1.

Message List. Where information (subject, date, sender, etc.) about messages stored in the currently selected
folder is displayed.

Message View Pane. Where the currently selected message’s contents is displayed.

Folder List. Where all folders are listed. The default folders are inbox (incoming messages), outbox (unsent
templates), sent-mail (already sent messages), trash (deleted messages) and drafts (draft messages).
There is also a special folder named Searches which contains the results of a search for messages.

1.1.1.3. KMail Usage

The following table shows the most important buttons available in KMail’s toolbar, their equivalent keyboard
shortcuts and a brief explanation of the functions they provide.

Button Keyboard Shortcut Function

Ctrl-N Compose a New Message. You need to complete the To and
Subject fields in the message-compose window.

Ctrl-L

Get new messages for all defined e-mail accounts. Keep this button
pressed to display a list of all defined accounts; select the one you
want to get mail from in order to retrieve messages only for that
account.

R Reply to the author of the selected message. A message-compose
window pops up with some fields already set.

F Forward (send to a third party) the selected message.

Del

Delete the selected messages. Deleted messages are moved to the
Trash folder. You can recover messages moved to the trash
folder, but deletion from the Trash folder cannot be undone: be
careful!
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Table 1-1. KMail’s Toolbar Buttons

Note: Some of those buttons have a little black arrow at the bottom right corner. An additional menu with related
actions can be displayed by pressing the mouse button a little longer.

1.1.2. Browsing the Web

Choose Internet→Web Browsers+Konqueror from the main menu to launch Konqueror. The home page
opens. Type in an URL in the Location bar to open a different page.

1.1.2.1. Browser Interface

Toolbar

Location Bar

Display
Area

Bookmarks
Bar

Tabs
Browsing

Figure 1-6. Konqueror Web Browser Interface

Toolbar. Contains all buttons used to navigate and perform common actions (see table 1-2).

Location Bar. Where you enter a site’s URL (or a local file using file:// as the protocol part of the URL).

Bookmarks Bar. Contains buttons which give you quick access to your favorite sites.

Tab Browsing. Allows you to open many sites in the same window instead of opening new windows, which
makes browsing much simpler.

Display Area. Where the contents of the web sites and local files you browse are displayed.

1.1.2.2. Surfing the Web

Button Keyboard Shortcut Function

Alt-left_arrow
Go back. Returns to the page you visited before the current one.
Keep this button pressed to display the list of all URLs you can
access.
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Button Keyboard Shortcut Function

Alt-right_arrow Go forward. Returns to the page you visited after the current one.
The same back-button considerations apply.

F5

Reload. Refreshes the current page. By default, Konqueror first
looks in the browser’s cache (on-disk temporary storage space)
and uses the local copy. Press the Shift key while clicking on the
reload button to force Konqueror to fetch the page from the
Internet.

Esc Stop. Aborts the transfer of the currently requested object and
cancels the page-loading operation.

Table 1-2. Konqueror’s Toolbar Buttons

Konqueror’s browser allows you to browse many web pages at a time by using tabbed browsing.

Creates and opens a new tab (Ctrl-Shift-N). Just type an URL on the location bar to open a new page on
this tab.

Tip: You can also press the Ctrl-Shift-D keys to duplicate the current tab, that is to open the same page you are currently
browsing, but on a different tab. This is handy for example with long pages allowing you to browse the same page in two
different positions at the same time.

Closes the currently displayed tab (Ctrl-W).

For bookmark management it is recommended you use social bookmark sites, such as Del.Icio.Us (http:
//del.icio.us), so you always have bookmarks with you on the go.

1.1.3. Chatting With Friends and Colleagues

Choose Internet→Instant Messaging+Kopete from the main menu to launch Kopete. A configuration
wizard appears.
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1.1.3.1. Configuring Kopete

Figure 1-7. Messaging Service Selection

Kopete supports communications with many popular messaging applications like MSN, Yahoo, ICQ, IRC, etc.
Select the messaging service from the list and advance to the next step. Please bear in mind that the different
messaging protocols have different configuration parameters. We show you how to setup an instant messaging
service account and then an IRC service account.
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Figure 1-8. Account Parameters

Then, you have to provide the account parameters: as a minimum a username (or email address) and a pass-
word; some messaging services might need other options too. Refer to the messaging service documentation
for more information on the account parameters to be set.

Tip: Most messaging services have a Register New Account button that you can click to get an account with that service,
if you don’t have one already.

Finally you are invited to connect to the messaging service and finish the messaging service configuration
wizard. Uncheck the Connect now option if you wish to connect later.

Choose Settings→Configure from the menu, then select the Accounts section and click on the New button to add
an account for a different messaging service. We now add an account for IRC server irc.freenode.net,
channel #mandriva, where you can get support for your MandrivaOne system from other users of Mandriva
Linux.
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Figure 1-9. IRC Basic Parameters

Provide your nickname1 and an alternate one (in case someone else already has registered the nickname you’ve
chosen), and optionally a username and a password.

Tip: It’s common to append a _ to the nickname to form the alternative nickname.

1. On IRC channels you are identified by your nickname. People will know you through it.
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Figure 1-10. IRC Network Parameters

Then, select the Connection tab and choose an IRC network using the Network pulldown list. You can also select
the default encoding and other options. Advance to the final step and finish the wizard.

1.1.3.2. Kopete Interface

Buddy List

Toolbar

Service

Status

Figure 1-11. IM and Chat Interface

Toolbar. Where the main action buttons lie. See table 1-3.

Buddy List. Where an entry is displayed for each of your buddies who is online, together with an icon iden-
tifying the protocol they are using. Buddy status is indicated as follows:

•
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The buddy is currently online and available;

•

the buddy is currently online, but not available. Depending on the messaging service you might be able to
send him messages anyway, which your buddy sees when he’s available again;

•

the buddy isn’t currently online, you cannot send him messages. Please note that you might not see this status
at all if you decide to hide offline buddies.

Service Status. One icon is displayed for each messaging service configured. If the icon is coloured, it means
you are currently online on that service, otherwise the icon is grayed. Right click on the service’s icon to access
a menu with actions for that particular messaging service.

1.1.3.3. Chatting and IM With Kopete

Button Function

Set Status. Displays a list of all possible online status. Just select the desired status from
the list. Please bear in mind that this status applies to all currently configured messaging
services. It can be thought of like a kind of global status setting.

Add Buddy. Select the messaging service from the proposed ones and then fill in the
buddy’s ID and optionally select a group using the Group pulldown list; click on OK to
add the buddy to your buddy list.
Popular messaging services (MSN, Yahoo, ICQ, Jabber, etc.) store the buddy list on the
server, so you get the same buddy list no matter where you connect to that service from.

When this button is pressed offline users are shown on the buddy list. This is handy to
see which buddies you have on your list for the different messaging services.

Table 1-3. Kopete’s Toolbar Buttons

To start chatting with a buddy, simply double click on his nick on the Buddy List. The window is divided in
two, you type on the lower frame, and see the conversation on the upper frame.

IRC is a bit different, you first have to join a channel on a server. Think of channels as chat rooms where you
can speak about a given topic. To join a channel:

1. Click on the IRC service status icon.

2. Select the Join Channel menu entry.

3. Type the name of the channel in the dialog box that appears. Channel names start with a sharp symbol
(#), for example #mandriva.

4. A window similar to the IM one appears, it also has a list on the right with the people connected on that
channel. If you don’t see the people list, it means you are alone on that channel, please try a different
channel or wait for someone to join that channel.

Repeat the above procedure to connect to other IRC channels on the same server, a window opens for each
channel you connect to so you can chat simultaneously on all channels you join.

There are many resources on the Internet about the so-called “netiquette”, which are norms and rules (some
can be described as common sense) one should observe for fair behavior when chatting with other people.
You can perform a search for “chat netiquette” (using Google) (http://www.google.com/search?q=chat+
netiquette) for more information.
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1.2. Doing Office Work

MandrivaOne can be used to perform office work with the OpenOffice.org office suite. OpenOffice.org tools are
Microsoft® Office-compatible, meaning you can easily exchange documents between them. We show you how
to write documents with OpenOffice.org Writer, spreadsheets with OpenOffice.org Calc and presentations with
OpenOffice.org Impress.

1.2.1. Writing Documents

Choose Office→Wordprocessors+OpenOffice.org Writer from the main menu to launch OpenOffice.org Writer.

1.2.1.1. Word Processor Interface

Format Bar

Rulers

Insertion
Point

Page
Style

Work
Area

Figure 1-12. OpenOffice.org Writer’s Main Window

Format Bar

This is the standard format bar used for all OpenOffice.org applications and is used to change fonts, colors,
alignment, etc. of the application’s data.

Rulers

Rulers define the horizontal location of the text and format elements. They are extremely useful when you
want to establish tabulation and paragraph indentation.

Work Area

Where you enter the content of your document: words, numbers, images, tables, hyperlinks, etc.

Insertion Point

All characters typed on your keyboard will be placed at the left of this point. Also called the cursor.
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Page Style

Page size, margins, text-orientation, etc. all define the style. Page style can be changed by choosing
Format→Page from the menu. You may use any one of the predefined styles or define one of your own.

1.2.1.2. Styles

Word processor users often waste a lot of time formatting (changing paragraph alignment, font family, weight
and size, etc.) their documents instead of using that time to concentrate on document structure and document
content writing.

Styles provide a structure-centric approach to writing documents with a word processor, while nor-
malizing document formatting and layout, and easily automating the generation and maintenance of
table of contents (TOC), indexes, references, etc. In OpenOffice.org Writer, styles are handled using the

Stylist, click on its icon in the Format Bar to open/close it.

When you have a... Then apply the ... style

Chapter Title Heading 1

Section Title Heading 2

Sub-Section Title Heading 3

Sub-Subsection Title Heading 4

Paragraph Text Body, First Line Indent

List Item List

Table 1-4. Suggested Styles

Use the styles listed in table 1-4, as a guide. Select the region of the document to apply the style to, and in the
Stylist window, double-click on the style you want to apply to that region.

1.2.1.3. Lists

Use lists to enumerate the properties of an object (“unordered” or “bullet” list), or the steps to be performed
in order to accomplish some task (an “ordered” or “numbered” list).

Click on this button to format the selected text into an unordered list. Select the list items and choose
Format→Bullets and Numbering from the menu to change the bullet type from a predefined set.

Clicking on this button will format the selected text into an ordered list. The same rules as for unor-
dered lists apply regarding to the numbering format.

1.2.1.4. Page Headers and Footers

By default page headers and footers are common to all pages of a document. Use them to describe certain
aspects about the document’s content, for example: page number, total number of pages, chapter, section,
document’s title, etc.

Choose Insert+Header→Default from the menu to add a page header to your document, and choose In-
sert+Footer→Default to add a page footer to your document. Just type the header/footer text you want to
be shown or use one or more of the Insert→Fields menu items to compose the header/footer.

1.2.1.5. Going Further

If you wish to learn more on the usage of OpenOffice.org Writer, you should consult the tutorial
available on the Tutorials for OpenOffice (http://www.tutorialsforopenoffice.org/category_index/
wordprocessing.html) Web site.
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Also don’t hesitate to refer to the OpenOffice.org Writer’s help which is accessible through the Help→
OpenOffice.org Help menu, or by pressing the F1 key. You are bound to find the answers to your
questions.

Tip:

OpenOffice.org is able to export your documents in PDF format (choosing File→Export as PDF from the
menu). This allows you to publish your documents in the Adobe® Reader® format.

1.2.2. Calculations and Simulations

Choose Office→Spreadsheets+OpenOffice.org Calc from the main menu to launch OpenOffice.org Calc.

1.2.2.1. Spreadsheet Interface

Format
Bar

Work
Area

Select
All

Formula
Bar

Sheet Changing
Buttons and Tabs

Figure 1-13. OpenOffice.org Calc’s Main Window

Format Bar

This is the standard format bar for all OpenOffice.org applications used to change fonts, colors, alignment,
etc. of the application’s data.

Formula Bar

Use it to enter, edit or delete formulas inside cells.

Work Area

Where you enter the data in the spreadsheet: numbers, dates, formulas, images, etc.

Select All

Clicking on this little area at the top left corner of the work area will select all cells at once. It’s useful
when you need to make changes which are “global” to the spreadsheet. For example, changing all font
sizes in the cells to 10pts (points).
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Sheet Changing Buttons and Tabs

Spreadsheets usually contain more than one sheet. Use these buttons to easily navigate through each of
the spreadsheet’s sheets. From left to right they are: Go to the first sheet, Go to the previous sheet, Go to the
next sheet and Go to the last sheet. You may also use the tabs to switch between sheets.

1.2.2.2. Entering Data

To enter data into a cell navigate to the cell and type the data in it, pressing the Enter key when you are
finished.

Auto-completion simplifies data entry “guessing” the next cell’s value using the current cell’s value as a base.
It works for any kind of data which can be associated to a series of integral numbers.

To use auto-completion put your mouse over the cell “handle” (the little black square located at the bottom
right of the cell border), click on it and drag the cell. The cell values will be shown in a tool-tip. Release the
mouse button to complete the cells once the desired final value is shown.

Cell data can also be sorted according to different criteria. Select the cells you want to sort and then open the
sort options dialog choosing Data→Sort from the menu. Specify the sort criteria, order and additional options
and click on the OK button to sort the cells.

Tip: Make sure you also select columns and rows which act as “headers” for the data in order for those to “follow” the
sorting of the data.

1.2.2.3. Adding Formulas

Formulas can be used to “automate” the spreadsheet allowing you, for example, to run complex simulations.
Within cells, formulas are defined by preceding all cell data with the = sign. Anything else is treated as “static”
data.

Operations are expressed using conventional algebraic notation. For example =3*A25+4*(A20+C34/B34)
divides the value in cell C34 by the value in cell B34, adds the value in A20 to the result, multiplies that by 4
and adds it to 3 times the value of cell A25. Thus, rather complex expressions can be made using simpler ones
as a base.

OpenOffice.org Calc gives you many pre-defined functions which you can use in your formulas, explore them
by choosing the Insert→Function menu.

1.2.2.4. Charts: Explaining Data in a Simpler Way

When a spreadsheet contains too much information it often becomes difficult to understand how pieces of
data relate to one another: too many numbers and too little meaning. The best way to represent this kind of
data is through a chart.

As in all data-analysis functions, you must select the region you intend to show in the chart. So, select a range
of cells and then chose Insert→Chart from the menu to bring up the chart assistant.

Make your selections for the chart type, variant, title, axis titles, etc. and then click on Create to create and
insert the chart in the spreadsheet.

Tip: Charts are“dynamic” in the spreadsheet which means that when you change data in a cell belonging to a chart, the
chart will be automatically updated.

Tip: Double clicking and then right-clicking on an inserted chart brings up a menu showing options to change many
chart parameters.
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1.2.2.5. Going Further

If you wish to learn more on the use of OpenOffice.org Calc, you should consult the tutorial available at the Tuto-
rials for OpenOffice (http://www.tutorialsforopenoffice.org/category_index/spreadsheet.html) Web
site.

Also, don’t hesitate to refer to OpenOffice.org Calc’s help accessible through the Help→OpenOffice.org
Help menu, or by pressing the F1 key. There you are bound to find answers to your questions.

1.2.3. Communicating your Ideas

Choose Office→Presentations+OpenOffice.org Impress from the main menu to launch OpenOffice.org Impress.
A wizard offers you assistance for creating a presentation, we will not detail it here, just click on its Create
button to create an empty presentation.

1.2.3.1. Presentations Interface

Toolbar

Work
Area

Slide Format Bar

Layout

TemplatesSlide

Navigation

Figure 1-14. OpenOffice.org Impress’ Main Window

Slide Format Bar

There are options for changing the slide shading, background color, line thickness, etc.

Work Area

Where you compose the slides which build your presentation.

Toolbar

It contains the main tools you use to create your slides: the text, shapes, curves, lines and arrow input;
object rotate, alignment and arrangement; and others.

Tip: Some of these buttons contain a little triangle on one side. Keeping these buttons pressed will open a menu
of options for that tool. For example: filled or hollow rectangles, sharp or round edges, etc.
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Layout Templates

Contains a gallery of the available templates. Just click on the template you want, to switch the current
slide to it.

Slide Navigation

Displays a list of all the slides composing the presentation. Slides are displayed miniaturized, so you can
see at a glance what they look like. To open a slide, search for it in the list, then click on it.

1.2.3.2. Adding Slides to your Presentation

Click on this button on the Toolbar or choose Insert→Slide from the menu to add a new slide, after
the current one, with the currently selected slide template.

Tip: Choose Insert→Duplicate Slide instead if you want to base your new slide’s content on the current one.

1.2.3.3. Simple Charts

Choose Insert→Chart from the menu to insert a chart diagram into the current slide. A “default” bar
chart will be inserted and OpenOffice.org Impress will change to chart mode. Click “outside” the chart
area to return to the slide design mode.

You can drag the border handles to adjust the chart’s size. Double click on the drawn chart, then right-click on
it and select Chart Data to enter the data according to the chart you want to build (see figure 1-15).

Figure 1-15. Entering Chart Data

Once you have entered the chart’s data, close the data entry window and click on the Yes button to update the
chart in the slide.

Repeat the double-click / right-click sequence in order to change the chart’s title, legends, axis, type (2D or
3D, bar, pie, points, lines, etc.) selecting the appropriate entries from the pop-up menu.

1.2.3.4. Slide Background

Use the Format→Page menu and click on the Background tab to define colors, gradients, patterns, or bitmapped
backgrounds for the slide. Each background type has options of its own, feel free to explore them.

Note: Using bitmaps for backgrounds increases the file’s size considerably. This could lead to a performance hit, especially
on older systems.

Once the background is selected you are offered the option to make that background the default one for all
slides. Make your choice and the slide(s) background(s) will be changed.
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1.2.3.5. Transitions, Animations and Effects

The Slide Show menu has slide transitions, animations and effects options/wizards which let you add “dy-
namism” to your presentations. However, you should try not to overuse transitions, animations and effects
because they can be distracting to your audience, turning their attention to the effects themselves instead of
the presentation’s content.

1.2.3.6. Running your Presentation

Choose Slide Show→Slide Show, or press the F5 key, to run your presentation. The presentation will take up the
entire screen. Press the Esc key to stop the presentation.

1.2.3.7. Going Further

If you wish to learn more on the use of OpenOffice.org Impress, you should consult the tutorial available at
the Tutorials for OpenOffice (http://www.tutorialsforopenoffice.org/category_index/presentation.
html) web site.

Also don’t hesitate to refer to the OpenOffice.org Impress’s help which is accessible through the Help→
OpenOffice.org Help menu, or by pressing the F1 key. You are bound to find the answers to your
questions.

1.3. Multimedia

With MandrivaOne you can play CDs, DVDs, video and audio files and burn CDs and DVDs. You can also use
powerful photo retouching software to manipulate images, for example the ones you download from a digital
camera.

1.3.1. Playing Music

1.3.1.1. Audio CDs

When you insert an audio CD in your CD drive a window pops up, if you choose to play the CD, the KsCD
player starts up.

Figure 1-16. KsCD’s Main Window

Tip:

Once KsCD is launched, this quick-launch icon appears near the clock. Right-click on it, to access KsCD’s main
features.
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On the left you have the typical CD player controls: Play/Pause, Stop, Eject, etc. The ones below alter the
playing order. The CDDB button can be used if your CD information doesn’t appear automatically, it displays
the CD’s title, artist and tracklist information. Click on the last button to access more advanced configuration
options.

1.3.1.2. Audio Files

Choose Multimedia+Sound→Amarok from the main menu to launch Amarok.

Playlist
Browser

Volume

Control

Play

Controls

Figure 1-17. Amarok’s Main Window

figure 1-17 shows the main interface components of Amarok:

Browser. This displays various information depending on the function selected using the tabs at its left.

Playlist. Where the files to be played are shown. Right click on any file to access a menu allowing you to play
the file, remove it from the playlist, etc.

Play Controls. Amarok’s play controls are “standard” audio equipment ones: Previous/Next Tracks, Play,
Stop. The Play button doubles as a Pause button too. Keep the Stop button pressed to select whether to stop
playing immediately or after the current playing song has finished.

Volume Control. Slide it right to increase the volume and left to decrease it. Right click on it and select Equalizer
from the menu that pops up to open an equalizer window where you can enhance bass and treble, and even
select some preset equalization curves.

The Collection browser enables you to view and organize your entire music collection. To use it, you
need to create a collection first: click on the Build Collection button, check all the folders you want
Amarok to look for music files and click Ok to start building the collection.

Warning

If you added files from removable devices (such as a USB key or an external hard drive), make sure they are mounted
at the same location as when you originally added them to your collection or Amarok won’t be able to find the
files they contain.

Then, start adding files to the Playlist by double clicking on them in the collection browser. Once satisfied with
your songs selection, simply press the
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(Play) button to start enjoying your music.

1.3.2. CD/DVD Burning

We concentrate on using K3b to perform common CD burning operations. DVD recording is very similar to
its CD counterpart.

Copyrighted Material. Please note that data, audio, video CD or DVD copying is often forbidden by copyright law. We
assume that if you want to duplicate copyrighted material, it’s because you have the right to do so.

Choose Administer Your System→Burn CDs-DVDs from the main menu to start K3b. figure 1-18 shows K3b’s
interface with a new data project open.

File
Manager

Project
Manager

Toolbar

Figure 1-18. K3b’s Interface

Toolbar. Where buttons to perform common actions lie: open and save projects, erase rewritable media, copy
CDs, etc.

File Manager. To choose which files to include in the burned CD. Use the left-side tree to navigate the file
system and drag and drop the files you want to include in the project into the Project Manager.

Project Manager. Where all files which will be on the burned CD are shown and handled. Files can be removed
and their location (directory) on the CD can be changed here.

1.3.2.1. Burning a Set of Files or Directories

Choose File+New Project→New Data CD Project from K3b’s menu . Then drop into the Project Manager the
files and directories you want to include on the CD (see figure 1-19).
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Figure 1-19. Selecting Files and Directories to Include on a CD

Note: Adding directories containing lots of files can take some time. Please be patient and wait until the Adding files
to Project PROJECT_NAME message disappears.

The space occupied by the selected files and directories is shown by a color-coded bar at the bottom of the Pro-
ject Manager, together with the volume expressed in MB and the available MB of the medium’s total capacity.
The bar’s color codes are as follows:

Green

The size of the set is less than that of the selected medium’s capacity (700 MB by default). There are no
capacity-related problems.

Yellow

The size of the set is nearly equal the selected medium’s capacity. If it’s a few MB below the medium’s
capacity, there won’t be any capacity-related problems; if it’s a few MB above the medium’s capacity, the
CD might be written without problems, but there’s little guarantee of success.

Red

The size of the set exceeds the medium’s capacity by many MB. The CD won’t be recorded properly.

Right-clicking on any file or directory in the Project Manager pops up a contextual menu with options to
remove and rename files, create new (empty) directories, etc. Files and directories can be relocated (change the
directory under which you want them to appear) on the CD using drag-and-drop.

Tip: Renaming the top element of the left side tree in the Project Manager changes the CD’s volume name (K3b data
project by default for data CDs).

Choosing the Project→Burn menu entry displays a window where you can select writing parameters (see
figure 1-20). Insert a recordable medium in the CD burner and click the Burn button to start writing the CD.
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Figure 1-20. Setting Writing Parameters

1.3.2.2. Burning Audio CDs (CDDA)

By audio CDs, we mean the ones you play in your car or home stereo equipment, not data CDs containing
OGG, MP3 or any other digital audio format files.

K3b supports recording audio CDs from tracks digitized in Wave (*.wav), Ogg Vorbis (*.ogg), and MP3 (*.
mp3) formats. You can mix digital audio formats since K3b decompresses the compressed ones on-the-fly. K3b
can also create digital audio tracks from audio CDs.

Choose File+New Project→New Audio CD Project from K3b’s menu. Select K3b’s File Manager’s filter to Sound
Files, navigate to where the digitized audio files are and then drag the audio tracks and drop them in the
Project Manager (see figure 1-21).
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Figure 1-21. Selecting Audio Tracks to Include on the CD

Use drag and drop to move the files up and down the compilation. Once you have the tracks compiled in the
order you want in the Project Manager, you can write them to CD.

1.3.3. Playing Movies

1.3.3.1. Video Files

Choose Multimedia→Video+kaffeine from the main menu to launch Kaffeine. The first time you launch
Kaffeine you are presented a configuration wizard, you can just advance through it accepting the
proposed settings.
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Play

Controls

Status

Sidebar
Display

Area

Figure 1-22. Kaffeine’s Interface

Kaffeine’s interface (figure 1-22) is comprised of the following:

Sidebar. The sidebar allows you to switch between Kaffeine’s windows, according to what you’re doing: view
Kaffeine’s start menu, listen to audio CDs, a playlist, and watch DVDs.

Play Controls. A reduced set of the usual VCR controls: Previous, Play/Pause (keyboard shortcut: Space Bar),
Stop (keyboard shortcut: Backspace) and Next.

Display Area. Where the movie being played is shown. Press the Ctrl-Shift-F keys to switch between full-
screen and windowed modes.

Status. Located at the bottom right of Kaffeine’s window, it shows information about the playlist and the movie
being played.

Choose File→Open to open a standard file open dialog allowing you to choose the movie you want to play,
select it and click Open, the movie starts playing immediately.

1.3.3.2. DVDs

When you insert a video DVD on your machine it starts playing immediately inside LinDVD. figure 1-23 shows
LinDVD’s interface. It is composed of two parts: the playback window, which looks like a TV screen, and the
DVD control window, which looks, and works, like a regular DVD player.
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Figure 1-23. DVD Playback Interface

1.3.4. Digital Photo Studio

Choose Multimedia→Graphics+digiKam from the main menu to launch digiKam. The 1st time you are
asked to provide a folder to store pictures into. You can accept the default /home/your_user_name/
Pictures.

1.3.4.1. Building a Photo Album

Choose Album→New Album from the menu and fill album properties (see figure 1-24), then accept
your settings to create the album.

Figure 1-24. New Album Settings
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Choose Album+Import→Add Images from the menu and use the standard file dialog to select the
pictures you want to add to your newly created album, then click on Add.

Tip: You can add all the pictures contained on a given folder by choosing Album+Import→Import Folders from the
menu and browsing for a folder, instead of files.

1.3.4.2. Rotating Pictures

Create a set of pictures and choose one of the entries (90o, 180o or 270o) of the Image+Rotate menu.

Many digital cameras store rotation information within the image file. In this case you can choose Image→
Auto Rotate/Flip Using Exif Information from the menu to have the picture rotated automatically in the correct
direction.

Warning

All transformations on pictures (such as rotation) are done on the on-disk file. digiKam doesn’t make a backup of
the transformed pictures. Also bear in mind that all transformations are, when possible, loss-less.

1.3.4.3. Touching-Up Pictures

Double click on a picture to open the image edit window. Note that all touch-up operations affect the quality
of the picture’s on-disk file. Also bear in mind that on-screen rendering is quite different from printing your
digital pictures on photographic paper. So if you intend to both print and publish your pictures for online
viewing, it might be wise to treat both copies differently from the beginning.

Tip: Press Ctrl-Z to undo the last transformation operation. However, once you have saved the image, changes cannot
be undone.
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Brightness, Contrast and Gamma

Choose Fix+Colors→Brightness/Contrast/Gamma from the menu and use the sliders to adjust the
brightness, contrast and gamma of the picture using the picture copy as a guide.

Sharpen

Choose Fix→Sharpen from the menu, drag the square to the part of the image to be used as a guide,
and use the slider to sharpen the picture.
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Red-Eye Reduction

Before After

Select the pupil of the eye to fix, choose Fix→Red Eye Reduction from the menu, and then select the
aggressive (only part of the eye selected) or mild (more than the eye selected) option to reduce the
red-eye flash effect. Repeat for the other eye, if needed.

Image Resizing and Cropping

Multi-megapixel images are excellent for photographic paper print-ups, but are far from adequate for
e-mailing or publishing on the web. Choose Transform→Resize from the menu, then select the desired
size, either in pixels or in percentage, and whether to keep (recommended) or not aspect ratio.

You can also crop an image to a desired size while keeping aspect ratio. Choose Transform→Aspect
Ratio Crop from the menu, drag the square to frame the part of the image you are interested on and
select the aspect ratio, orientation, width and height (one follows the other according to the aspect

ratio selected).
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Tip: For electronic publication, the usual aspect ratio is 4:3, while for printing the usual aspect ratio is 3:2.

Usually a size of 640x480 is enough for e-mailing a photo, while 800x600 is enough for web publishing.
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Once your Live CD session is running, you may want to install and configure peripheral devices, such as your
printer, scanner, webcam or digital camera, etc. Mandriva Linux is well-known as one of the smoothest and
least problematic Linux distributions to install because of its extensive support for a wide range of computer
hardware. If you experience problems, check the Mandriva Linux Mandriva Linux Hardware Compatibility
List (http://www.mandriva.com/hardware/).

2.1. The Mandriva Linux Control Center

The Mandriva Linux Control Center is an operating system setup and configuration tool. Mandriva Linux Control
Center makes setup and configuration of peripheral devices a simple "click and go" procedure, when it’s not
fully automated.

During this chapter you will use a number of the hardware related tools the Mandriva Linux Control Center has
to offer. The Mandriva Linux Control Center is started by selecting Main menu+System+Configuration→Configure
Your Computer.

For the purpose of this chapter we will be using the tools under Hardware.

Figure 2-1. Hardware Tools

2.2. Setup your Printer

Setup of printers is made easy using graphical tools that automate most of the process of detecting and insta-
lling appropriate software for attached printer devices.
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Tip: If you are installing an HP all-in-one device (printer, scanner, fax), and want to use the scanner component, please
install the printer using HPLIP, an HP developed solution for printing, scanning, and faxing with HP inkjet and laser
based printers. If you setup without HPLIP Mandriva Linux will not detect the scanner component when you come to
install it.

Once you have setup your printer, any software with print capabilities will be able to print to it. The list below
provides examples:

• The OpenOffice Suite - word processor, spreadsheet, presentation, database, equation editor and drawing
tool.

• The GIMP - an image manipulation program.

• showPhoto - an application for management of photographic images.

• Konqueror - The KDE Web Browser and File Manager.

2.2.1. Installing a Printer

The procedure below steps you through the process of installing a printer. Before starting, ensure that your
printer is connected to the parallel or USB port of your computer and is powered on.

Installing a Printer

1. Start the Mandriva Linux Control Center.

2. Click the Hardware button.

3. Click the Setup the printer(s), the print job queues, ... tool.

Printer detection will start to interrogate your system for printers attached to the system and network
shared printer resources.

4. When prompted to “Start the printing system at boot time”, click the Yes button.

Wait for the detection process to complete.

5. When the list of detected printers is displayed, check the checkbox option Do not setup this
printer automatically again, then click the OK button.

6. When prompted that you have turned off the automatic printer setup feature, click the OK button to
proceed.

The remainder of the procedure is automatic. Wait for the selected printer to be configured. Depending on
the printer you are installing, additional configuration messages may be displayed. Follow the instructions
provided. The automatic configuration process may take a few minutes, just wait for it to complete, do not
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cancel it. You will know it is finished when the Printers management interface is displayed. The newly installed
printer should be listed and marked as Default and Enabled.

2.2.2. Configuring a Printer

Newly installed printers are automatically configured with default settings provided by the printer driver and
regional settings of your system. You may wish to change the default settings to your own preferences.

Configuring a Printer

1. From the Printers management interface select the Configured on this machine tab.

2. Select the printer you wish to configure, then click the Edit button.

The Modify printer configuration dialog is displayed. For the purpose of this procedure, we will change
the Page size parameter using the Printer options item.

3. The Printer default settings dialog is displayed.
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4. From the Page size drop-list, select the page size you require, then click the OK button.

Managing Printers and Queues in KDE: Default printer settings can also be changed from within the KDE Control
Center (Main menu+System+Configuration→Control Center) using the Printers applet, located under the Peripherals
category. This will save some time when reconfiguring printer settings for already installed printers, as the Mandriva Linux
Control Center, Setup the printer(s) tool searches for newly installed printers each time it is started.

2.2.3. Testing a Printer

It is useful to test newly installed printers to see if they work. It is also useful to test printers when changing
printer settings or when changing ink.

Testing a Printer

1. Select the printer you wish to configure, then click the Edit button.

2. Select the Print test pages item, then click the Do it!.

3. Check either or both the test page types, then click the Print button.

The print job is sent to the printer. Once the job is sent, status messages will provide feedback.

4. When notified that the print job has been sent and that the printer is printing, click the OK.
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You are returned back to the Modify printer configuration dialog where you can continue to configure and
test the printer.

If the selected test page(s) print then your printer is installed and serviceable. If not, then review the printer
settings and try again.

Tip: It is also possible to test an installed printer from within the KDE Control Center, using the Printers applet located
in the Peripherals category.

Display the Control Center by selecting Main menu→System→Configuration→Control Center. Then select Peripherals→
Printers. When the interface is loaded select the printer to test and select Printer→Test Printer. Click the Print Test
Page button.

While this test does not give you options to print a Photo test page, it does enable you to view the print queue and
control print jobs.

2.3. Setup your Scanner

Note: If you are installing an all-in-one device, please setup and configure the printer component as described in Setup
your Printer , page 33 before starting this section.

Many software applications provide capabilities to capture images directly from scanner devices, examples
include:

• The GIMP - an image manipulation program.

• Kooka - an image scanning program.

• OpenOffice.org - Writer - a word processing program.

2.3.1. Installing a Scanner

A scanner is normally connected to a computer using a USB connection. However, some scanners are connec-
ted using the parallel, or Small Computer System Interface, commonly called SCSI.

With your scanner attached to the computer and powered on, start the Mandriva Linux Control Center, then
select Hardware. The procedure below will step you through the installation process.

Installing a Scanner

1. Click the Setup scanner icon.

The Setup Scanner application will scan your system for attached scanner devices.

2. When complete, a list of scanner devices will be listed, this means your scanner was found and automati-
cally setup using default options. Click the Quit.
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2.3.2. Testing a Scanner

The best way to test if a scanner works properly is to scan something. To scan you need to use a program that
provides the functions to capture from a scanner device. For the purpose of this test we will be using Kooka,
an application for scanning.

Testing a Scanner

1. From the Main menu select Multimedia→Graphics→Kooka.

The Kooka setup wizard is displayed with a list of installed scanner devices.

2. Select the scanner device you will be testing, then click the OK button.

3. Place an item to scan in the scanner, then click the Preview Scan button.

The scanner will warm up and scan the item. The resulting image is displayed in Kooka.

If the scanned image is displayed, then your scanner is installed and working correctly.
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4. Click the Final Scan button if you want to save the scanned image to a graphic file format.

2.4. Setup your Webcam

Most webcam devices are connect to computer systems using a USB connector, better quality webcam devices
require a parallel port to interface with a computer. In Mandriva Linux a webcam device is considered to
be a scanner. As a result the installation process follows the same steps as those used to install a scanner. In
most cases, webcam devices will be automatically detected. However, webcam devices can also be manually
installed.

Before proceeding with this section, please ensure that your webcam is connected to the computer.

2.4.1. Automated Webcam Installation

With your webcam attached to the computer, start the Mandriva Linux Control Center and select Hardware. The
procedure below will step you through the installation process.
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Installing a Webcam

1. Click the Setup Scanner icon.

The Setup Scanner application will scan your system for attached scanner devices.

2. When complete, a list of scanner (webcam) devices will be displayed. Check the list to determine if your
webcam device was detected correctly.

2.4.2. Testing a Webcam

To test a newly installed webcam you need an application that provides support for viewing video. For the
purpose of this test we will use Kopete, an integrated instant messaging communications application. A mes-
saging account is not required in order to test the webcam. However, if you want to use the webcam for
video conferencing with friends, it is recommended. The procedure to setup messaging accounts with Kopete
is described in Chatting With Friends and Colleagues, page 9.

Testing a Webcam

1. From the Main menu select Internet→Instant Messaging→Kopete.

2. Continue the wizard for one of your instant messaging accounts, or click the Cancel button.
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3. From the menu select Settings→Configure.

Click the Devices menu item, and the Video form is displayed with the video image displayed in the top
part of the form.

2.5. Use your Digital Camera

Some Digital Camera devices are detected as Camera and others are detected as Mass Storage Media. How
Mandriva Linux will detect your device, depends on the camera type.

Connecting and Disconnecting your Camera. Most digital cameras connect to a computer using a USB in-
terface. When connecting a Digital Camera it is good practice to power on the device only after it has been
connected to the computer. The inverse is applicable when removing the device. Ensure that the camera is
powered off before disconnection.
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Camera as a Mass Storage Media

1. Plug and power the camera on. If the following popup shows, that means it is recognized as a storage
media. Otherwise, see Transfer and Process Images with Digikam, page 42.

2. Click OK, the file browser opens, showing the content of the camera folders. You can then copy the images
to your local folder to further process or display them.

2.5.1. Transfer and Process Images with Digikam

The nicest way to use a Digital Camera with Mandriva Linux is with the help of digiKam, a digital photo mana-
gement application.

Configure your Digital Camera

1. Select Main menu→Multimedia→Graphics→DigiKam to start digiKam.

The Images Library Path dialog is displayed.

2. Select the folder in which you want to store photographs, then click the OK button to display digiKam
main interface.

42



Chapter 2. Installing and Configuring your Peripherals

3. From the menu select Camera→Add Camera. to display the Configure dialog.

4. Click the Auto Detect button.

Your Digital camera should be listed in the Cameras list. Click the OK button to return to theDigikam main
interface.

Import Photos

1. Your camera now appears in the Camera menu. Select the menu entry corresponding to your camera, this
opens the camera thumbnails window.
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2. Select Download→Download All

3. Click New Album, and enter the album name, click OK again at the album choice dialog.

4. All images are now transferred from the camera to the album chosen. Click Close to go back to the main
digiKam interface and browse your albums and pictures.

Digikam is a Complete Images Handling Application. To learn how to use its many features, consult
The digiKam Handbook (http://docs.kde.org/development/en/extragear-graphics/digikam/index.
html) and The digiKam Image Plugins Handbook (http://docs.kde.org/development/en/extragear-graphics/
digikamimageplugins/index.html).

2.6. Memory Card Readers

Memory card readers allow rapid transfer of files from memory cards typically used by Mobile phones, PDAs,
MP3 players and Digital Cameras. Some card readers are able to read multiple memory card types, including:
SD Card, MultiMediaCard, CompactFlash, SmartMedia, Microdrive, MemoryStick, MemoryStick Pro and Me-
mory Stick Duo (with adapter). Memory card readers use a USB interface to connect to a computer.

Insert a memory card into the reader, an icon for it is created on the desktop and a window appears notifying
that a new medium has been detected.
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If you have multiple cards in the device, at the same time, each card will have a corresponding desktop icon.
Just double-click on the desktop icon corresponding with the memory card you wish to use. The contents of
the memory card are then automatically displayed using the file manager. You can now copy or move files
between different media and delete files and folders on the memory card as required.
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3.1. Free Linux Games

As you can see in the software installer (see “Package Management”, page 57), Mandriva Linux offers a wide
variety of games to be installed, sorted by category.

Figure 3-1. Installing Games

The game quality varies greatly from one to another, so it’s better you just test them and make your choice
according to your taste. We’re only highlighting a few of them here.

3.1.1. Frozen Bubble

• Package: frozen-bubble

• Menu: More Applications+Games+Arcade→Frozen Bubble

This arcade-type game consists of firing colorful bubbles to build groups of at least three-of-a-kind bubbles.
Once you get three, they fall off and you go shooting at other bubbles before your time runs out. It features
100 levels for a one-player game; finish the level quicker than your opponent in 2-player mode. Great stereo
music and sound effects. Don’t make that little penguin at the bottom of the screen cry!

How long will you be addicted?
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3.1.2. Supertux

• Package: supertux

• Menu: More Applications+Games+Arcade→SuperTux

One of the most interesting games is a clone of Super Mario called SuperTux (http://supertux.berlios.de/).
It features Tux the Penguin as he tries to save his beloved Penny from the arms of his arch-enemy, Nolok. The
first milestone of this game features 26 levels and 9 enemies which you must help Tux jump over, squash or
shoot at. Try out the 2 bonus levels and you can even draw up your own levels with the level editor.

3.1.3. X-Moto

• Package: xmoto

• Menu: More Applications+Games+Arcade→X-Moto
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Ride your all-terrain motorcycle through beautiful, but hard, landscapes while collecting fruit to achieve the
goal: get a nice flower for your beloved one. Impressive physics and nice graphics make this game a joy to
play. Make your choice from predefined levels, download levels from X-Moto’s home page (http://xmoto.
sourceforge.net) on the Internet or create your own. You can also save replays of your rides to watch later
or show them to your friends. Start your engine and go ride your bike!

3.1.4. KDE Cute Games

• Package: kdegames

• Menu: More Applications+Games
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Boards

Play classic board games such as chess, backgammon and battleship! Some games are network-enabled
such as chess (check out the Free Internet Chess Server (FICS) (http://www.freechess.org) for instance).

Cards

Bored out of your mind? How about a quick game of patience or poker? Start off your KPoker game with
a 100$ and... try not to lose it all!

Strategy

Spend a few minutes (or a few hours...) demystifying games such as KSokoban, KAtomik or SameGame.

3.1.5. StepMania

• Package: stepmania

• Menu: More Applications+Games+Arcade→StepMania

Who said computer gaming is not a sport? StepMania will make you sweat in front of your monitor.

Requirements

• Good sound.

• A USB Dance Pad.

Installing the Songs

By default, StepMania comes with no songs. To install them, follow these steps.

1. Connect to the Stepmania Songs Download Section (http://www.stepmania.com/wiki/Download_
Songs), and download a song pack, opening it in the archive manager.

2. Create a StepMania directory in your home folder, and extract the archive content in it.

Start the game. All is now set for you to play! Start StepMania from the main menu, and follow the on-screen
instructions. Have fun.
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3.2. Run Windows® Games on Mandriva Linux

• Package: cedega

• Menu: More Applications+Games+Transgaming→Cedega

Cedega. Cedega is an application that enables gamers to play dozens of Windows® titles on GNU/Linux, such as
Battlefield 2, Elder Scrolls IV: Oblivion, World of WarCraft, Civilization IV, Madden 2006 and many more1. So
if you already have a game you used to play on Windows®, Cedega allows you to run it under Mandriva Linux.

Technical Requirements

TransGaming recommends the following specifications to achieve optimal game play:

• Sufficient hard disk space for the installation of games plus 60MB for Cedega

• nVidia GeForce class video card

First Time Setup Wizard

1. Fill in your TransGamer account information2, and check the Check for updates box.

2. Check all boxes in the updates dialog, and install them all.

3. Change the Hardware information if required, but you probably don’t need to.

4. Run all system tests by clicking Run Selected Tests. It’s best if all checks pass successfully.

Figure 3-2. Cedega Main Interface

1. Consult the available games database (http://transgaming.org/gamesdb/).
2. Check the instructions in your Mandriva box to obtain this account.
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Figure 3-3. Click Install to Start Installing Games

Installing a Supported Game from Disc

1. Insert the CD or DVD and click Detect Game Disc.

2. If it works, click Continue and follow the game installation instructions. Otherwise, use the following
procedure.

Install Games Manually

1. In the Game Folder field, enter the name of the game you are installing. This can be any description you
like.

2. Enter the path to the installation executable in the Installer field, or use the Browse button to select the
installation executable. The executable is often setup.exe, install.exe or autoplay.exe, and is often
located in the root directory of the program CD. This name may vary, however, depending on the game.

3. Click Continue and follow the game installation instructions.

Play! The game now appears in the left column. Select it and press the Play button.

3.3. More Games

If you want to learn more about gaming on GNU/Linux please check out these links:

Happy Penguin (http://www.happypenguin.org)

Here you will find a database of known games, a FAQ, a user forum and a list of the hottest GNU/Linux
games.

LinuxGames (http://www.linuxgames.com/)

Linux games news
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You can easily give your friends a copy of the CD/DVD so they can install it on their systems, or install the
Live CD/DVD to your own system’s hard disk following a few simple steps.

4.1. Live Copy

Click on this icon on the desktop to start the CD/DVD copy wizard. You are asked the medium type
you want to copy to: select from either cdrom or usb1. You are then asked the device containing the medium
and if you want to format it or not. Have in mind that “-R” optical media need not to be formatted. Make sure
the medium is ready and click on Finish to start the copy.

4.2. Live Install

4.2.1. Copy Files to Hard Disk

Click on this icon on the desktop to start the install wizard. The following steps are performed:

1. Where to Install Mandriva on your Hard Disk

Depending on what you currently have on your hard disk, you can now choose where your new Mandriva
system will reside. Bear in mind that reusing existing partitions of an former operating system or deleting
them will result in data loss. If you select the Custom disk partitioning option, you can control your partitions
using DiskDrake (see Managing Your Partitions in Starter Guide).

2. File Copy

Then, files are copied to the hard disk, no intervention is required on your part. This usually takes a few
minutes, depending on your system’s speed.

3. Bootloader setup

This step installs the menu that allows you to choose which operating system to boot at machine startup.
You can safely accept the default settings. Click on Advanced if you need to have access to more configu-
ration options.

4. Finish

Just click on the Finish button and then restart the computer (Main menu+Log Out+Restart Computer),
removing the CD/DVD when prompted to.

4.2.2. System Configuration

A few settings have to be configured after the system boots from the hard disk.

4.2.2.1. Networking

This is basically divided in two: selecting the network type; and configuring the required network parameters,
which depend on the network type selected. Make sure you have all the required network settings (depen-
ding on the network type: IP address, DNS servers, gateway IP address, etc.): your ISP or system/network
administrator should have provided them.

1. The USB key must be at least 1GB to host the system.
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Figure 4-1. Choosing the Connection Type

Dial-up Connection. Select the Analog telephone modem (POTS) network type.

Cable-modem. Some cable-modem connections require you to select the Ethernet network type. Check with your ISP
or system/network administrator.

Cellular Networks. To connect to a wireless cellular network type, choose the GPRS/Edge/3G entry.

1. Connection Type

Your network device is automatically detected according to the network type you selected. If this is not
the case, you have the option to manually select the network device.

2. Network Parameters

Fill all required parameters for the connection type you chose.

3. Connection Status

After setting up all of the parameters, you are asked if you want to start the connection at boot; unless you
have a dial-up connection type (or any other “not-always-on” type), leave the box for this option checked.

4. Finally, you are asked to connect to the network to test everything works as expected. If something fails,
go back, check and change the settings as required. You are now connected to the network, click on the
Finish button.

4.2.2.2. Root Password

The root user is the system’s administrator, and basically can do whatever he wants with the system, so it’s
extremely important to select a good, hard to guess, password to protect the root account. This password
will be asked of you whenever you wish to do administrative tasks (such as installing new software) on the
system.

Choosing a good password: The password should be a mixture of alphanumeric characters and at least 8 characters
long. Never write down root’s password — it makes it far too easy to compromise your system. One caveat: do not
make the password too long or too complicated because you must be able to remember it too!
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The password is not displayed on screen as you type it. You are asked to enter the password twice, for confir-
mation. Please note that if you type it incorrectly, you have to use this “incorrect” password at least on the 1st

login as root, so please type carefully.

4.2.2.3. Create User Accounts

You must create an unprivileged (also called “regular”, or “normal”) user for everyday usage of the system.

1. Fill in the fields with the required information and then click on Accept user to create the account. Please
note that even if this user’s password is not as crucial as root’s there’s no reason to neglect it or leave it
blank, after all its your files which are at stake.

2. If more people are going to use the system keep creating users for all of them, then click on Done when
you have finished adding users.

4.2.2.4. Registration Wizard

Whether you already have Mandriva accounts or wish to register your new product to benefit from all as-
sociated advantages, this wizard will guide you to do so. Make sure you read explanations carefully before
advancing, or click on Skip wizard to skip it altogether.

Once this is done, the system is ready to be used, just go ahead and provide your credentials (username and
password) to start using the system.
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To begin with, a bit of vocabulary.

Package
Software needs to be broken down into different files to ease its development and management. An
application ends up being lots of pieces: the binaries, the documentation, the resources the application
needs (images, icons, translations, sounds, etc.). A package is the set of all of an application’s components,
stored in a single file in a way that’s very simple to install, update and remove.

Dependency
Applications rely on software libraries or components made by different developers to perform a given
set of functions, not part of the main functionality but needed to achieve it. A dependency is a package
another package needs in order to work properly. Mandriva Linux’s package management tool takes care
of all the dependencies automatically.

Update
Software is a living thing: new features are added, existing ones are enhanced and problems (bugs) are
fixed. An update is a package which brings in some or all of these enhancements and fixes into an existing
application. It is recommended that you check for updates often in order to keep your system in good
shape and free from bugs and security threats.

Source
A source is a repository of packages, and the place where packages are installed from. Sources for the
media used during system installation are automatically created, you can add your own sources for
updates and packages you find on the Internet.

Mandriva Linux uses the RPM packaging system. Mandriva Linux provides convenient tools to simplify packa-
ge maintenance. The urpmi set of tools is command line based; here we will concentrate on Rpmdrake: Mandriva
Linux’s graphical software installation tool and the Software Media Manager. figure 5-1 shows the Software Ma-
nagement section of Mandriva Linux Control Center.

Figure 5-1. Software Management in the Mandriva Linux Control Center

Rpmdrake can be used in one of three modes: install
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, remove

and update

, each explained in Adding, Removing and Updating Software, page 58. Media management is covered in
The Software Media Manager, page 60.

5.1. Adding, Removing and Updating Software

When launching Rpmdrake you have to wait a few seconds while the package databases are scanned. Then
you are presented with Rpmdrake’s main interface.

Package

Details

Package

List

Categories

Tree

Package

Search

Package

Set

Figure 5-2. Rpmdrake Interface

Package Set. Use this pulldown list to select the types of package to be displayed: all of them (installed or not);
only installed ones (to be uninstalled); only uninstalled ones (to be installed); and a few options for updated
packages (all, security fixes, bug fixes, normal updates). Each time a package set is selected, the Categories
Tree is rebuilt to display matching packages only.

Package Search. If you are not sure about a package name, use this facility to search for it. Type the string to
be searched for, select the critera using the pulldown list, and click Search. You can search for package names
(in names), package descriptions (in descriptions) and the package providing a given file (in file names).

Note: If your software media repositories are configured to use the synthesized package lists (the summary synthesis files,
not the full hdlist ones) you will not be able to look for the package providing a given file. You will only be able to
search for package names and descriptions.

Categories Tree. To ease management, packages are classified into categories (Networking, Office, Games,
Development, Graphics, etc.). Open a category to display packages which match the current criteria set using
Package Set and Package Search.

Package List. Where currently matching packages (Set, Category and Search Criteria) are displayed. This is
where you select packages to be installed, removed and upgraded.

Package Details. Displays details about the currently selected package in the Package List.

Note: Additionally, a status bar in the lower part of the window displays messages about actions currently in progress or
completed.
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Actions on Packages

1. Limit List of Packages Displayed

Use the Package Set pulldown list, the Categories Tree and, optionally, the Package Search facility to brow-
se for packages to be installed, removed or updated.

2. Select Packages

In the Packages List, select packages to be installed, removed or updated. If the checkbox by the package
name is empty, it means that the package can be installed or upgraded, once selected it will be marked
with the

icon. If the checkbox by the package name has the

icon, it means the package is already installed, select it for removal.

3. Apply Changes

Once you are satisfied with your choices, click on Apply to perform the actual install, remove and upgrade
of these packages. A new window appears, where you can see the progress of actions being taken. If you
prefer to leave without doing anything, you can just click on Quit.

Handling Dependencies

It may happen that you select a package which requires dependencies (additional libraries or another tool)
or which is a dependency of other packages. In this case Rpmdrake displays an information window allowing
you to choose whether to accept the selected dependencies, to Cancel the operation, or to get More info on the
operation (figure 5-3).

Figure 5-3. Dependency Alert Box

Alternative Dependencies. You may also want to install a package which requires dependencies, and various
packages are capable of providing that dependency. The list of alternatives is then presented (figure 5-4).
You may read the additional information presented by clicking the Info... button to help you choose the best
alternative.
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Figure 5-4. Alternative Packages

Note: Due to dependencies, the disk space required by the selected packages might be greater than the size required by
the chosen package by itself.

5.2. The Software Media Manager

Use this tool to configure the package media repositories. figure 5-5 shows some media already
defined: “Main”, “Contrib”, etc. You can also add other software media: a CD from a magazine
containing RPMs, a Web repository, etc.

Figure 5-5. The “Software Media Manager”

Use check boxes of the left-hand columns to flag the repositories

Enabled?

Uncheck this box to temporarily disable the corresponding medium. The packages contained in this me-
dium will not be available until you enable the medium again.
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Updates?

This box must be checked for update media, that is, media that contains updates of packages that are
already in another medium, albeit with an older version number. Thus only update media are taken into
account when looking for updates.

Action Buttons on the Right

Remove

Discard a medium which you no longer use. Simply select the medium to be removed in the list and click
this button.

Edit

Change the medium’s parameters: the URL or the relative path to the synthesis/hdlist (if you do not
know what we are talking about it is wise to leave this window via Cancel instead of Save changes).

In case you need to pass through a specific proxy to access this particular medium, you can configure it
here by clicking on Proxy.

Add

Add to your system all publicly available official package sources from Internet repositories. This is useful
for example if you have a fast Internet connection or only have the first installation CD at hand. Choose a
mirror geographically near to your location.

After choosing a mirror and clicking Ok, package information for the source you chose is downloaded
and all included packages will be available.

Add custom

This button provides access to a new dialog, in which you define all needed parameters for a new software
package medium. Please bear in mind that the required parameters, and available options, depend on the
type of medium being defined.

Figure 5-6. Adding a Custom Package Repository Media

Update

You are shown a list of already defined, enabled, media; select the ones you want to update the list of
available packages for, and click Update. This is useful for remote media to which new packages are being
added.

Manage keys

It is important that any package you install is authenticated. To do so, each package can be electronically
signed with a “key”, and you can allow/disallow keys on a per-medium basis. On figure 5-7, you can see
that the Mandriva Linux key is allowed for medium “Main”. Click on Add a key to allow another key for
the selected medium (beware, do this with care, as with all security-related questions), and on Remove key
to remove a key from the selected medium.
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Figure 5-7. Package Repository Authentication Key Management

Proxy

If you are sitting behind a firewall and you still need to access remote media (especially for package
updates), you can do so if you have a proxy server which leads to the Internet (at least in an area where
you can find a package server). Normally it should be enough to fill in the Proxy hostname to get it working
(figure 5-8). If you need a user / password combination to get through the proxy, you can also specify
these here. Just confirm your changes by clicking on OK and you are done.

Figure 5-8. Specifying a Proxy for Remote Media

Parallel

If you are running a large network of computers, you may want to install a package on all the computers
in parallel; this button opens a dialog window allowing the configuration of the “Parallel” mode. As it
is rather complicated and only useful to a limited group of people, this short introduction will not give
further details about it.

Global options

This button allows you to configure the program used to retrieve remote packages and whether the pac-
kages should be checked against a key. These choices affect all package sources.

Up and Down arrows

These buttons allow changing the order in which sources will be used when installing packages. By de-
fault, the newest version of a given package will always be installed, but if the same version is found on
two different media, the one from the first medium in the list will be installed.

Tip: Therefore, it is better to move fastest media up...
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6.1. Configuring your Hardware

6.1.1. Hardware Detection and Configuration

The HardDrake project has been developed to simplify hardware detection and configuration
under GNU/Linux by providing a user-friendly interface.

6.1.1.1. What Is HardDrake?

HardDrake is a service for hardware detection, run at system boot time, and also a full GUI-based tool which
ties together many of the tools already included in a GNU/Linux distribution. It automates and simplifies the
process of installing new hardware. For the most part, HardDrake will be able to detect most devices.

On one hand, HardDrake is used to display information, and on the other, it can launch configuration tools.
With its easy-to-use interface, you can browse all the hardware your system contains.

6.1.1.2. Usage

To launch HardDrake, you can start it through:

• the Mandriva Linux Control Center: click on the Hardware category, and then on the Hardware icon.

• a terminal: type harddrake2 as root. You can also pass parameters to HardDrake through the command
line (type harddrake2 -h to get a list of possible parameters).

• the desktop: go to the main menu. The HardDrake entry is in the System+Configuration+Hardware→HardDrake
sub-menu.

After all devices have been detected, the main HardDrake window appears (see figure 6-1).

On the left, you can see the device tree showing you all of the hardware categories.

Figure 6-1. Selected Device
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By selecting a device, you will see additional information about it in the right frame. To better understand
the meaning of the information presented, you can consult the help page accessible by choosing Help→Fields
description from the menu.

Depending on the device selected, two other buttons may appear:

• Set current driver options. This pops up a window with all the module device parameters listed. For experts
only!

• Run config tool. Launches the Mandriva Linux configuration tool (available through the Mandriva Linux
Control Center) associated with that device.

Unknown hardware. A special category called Unknown/Others might also show up, containing all the
currently unknown hardware in your system, as well as known hardware that does not fit into the existing
categories (such as thermal sensors, random number generators, etc.).

6.1.2. Problems/Troubleshooting

If you think you have found a bug related to HardDrake, report it using the Mandriva Linux bug reporting tool.

Sound Cards. HardDrake does not probe for ISA PnP devices. If you have an ISA PnP sound card, run
sndconfig or alsaconf from the command line. You may need to install the sndconfig package or the
alsa-utils package.

6.2. Controlling the Graphical Configuration

This set of tools allows you to configure your graphical display. With it you will be able to change your
video card, your resolution and your monitor. It can be useful if you happen to change one of your graphical
components after the initial installation.

If you Don’t See Graphical Login at Boot: If the graphical server cannot start because of a configuration error, a
dialog offers to reconfigure the graphical server. You will get a tool similar to the one described in Controlling All Video
Parameters, page 66, but in text mode.

The graphical configuration tools are accessible through different icons in the Mandriva Linux Control Center
Hardware section.

6.2.1. Changing the Monitor

This tool allows you to change the monitor type currently in use. When you click on it a window
pops up, listing many monitor models (see figure 6-2). If your monitor was automatically detected
it is listed as Plug’n Play along with its model.
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Figure 6-2. Choosing a New Monitor

If your monitor wasn’t automatically detected, you can choose it from the list. If you don’t find your monitor
or a compatible one, choose one with parameters corresponding to your own monitor from the Generic entry,
at the bottom.

6.2.2. Changing Resolution

This tool enables you to change the current screen resolution (800x600, 1024x768, etc.) and the
color depth. Simply choose the one you wish to use.
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Figure 6-3. Changing the Resolution of your Screen

The monitor in the window displays what the desktop will look like with the chosen configuration (see figure
6-3). If it looks good, click on OK. The changes will be activated after you quit and restart your graphical
environment.

Monitor and Resolution Ratio. By default, the available resolution list only shows resolutions supported by
your video card and monitor combination. There is a special entry named Other which adds more possible
resolutions along with their ratios. Bear in mind that most monitors are designed with a 4:3 horizontal vs.
vertical ratio.

6.2.3. Controlling All Video Parameters

If you happen to change your video card after installing your system, or want to have full control
over the graphic configuration, run this tool.
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Figure 6-4. XFdrake Main Window

The first three buttons allow you to change certain aspects of the graphical configuration:

Graphic Card

The button displays the name of the graphic card currently configured. If you wish to change it, just click
on it. Depending on your card, different servers may be available, with or without 3D acceleration. You
may need to try different ones until you get the best result.

In case you cannot find the graphic card you have, but you know which driver supports it, select it from
the Xorg entry at the bottom.

Monitor

Enables you to change the monitor with the tool described in Changing the Monitor, page 64.

Resolution

Enables you to change the pixel resolution and the color depth with the tool described in Changing Reso-
lution, page 65.

Changing the Resolution Using the Desktop Applet: If you are using KDE you can also change the screen resolution
on the fly by using the screen resize applet, accessible choosing System+Configuration+Hardware→KRandRTray from
the main menu.

Then, there are more buttons:

Test

Click on this button to verify that your modifications actually work. It is highly recommended that you
do test it, because if it does not work, it will be harder to recover a working graphical environment later.
If the test fails simply wait until it ends. If you are not satisfied with the suggested settings, choose No
during the test, and you will be returned to XFdrake’s main menu.

If the Test is Not Available: Depending on your video card, video testing may not be available. You will be warned
of such a situation. If it happens that the settings are incorrect and your display does not work, launch XFdrake
as root in the console to use XFdrake’s text version.
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Options

Graphic card options

Depending on your hardware capabilities, you can choose here to activate or disable specific features
such as 3D acceleration or special visual effects (translucency).

Graphical interface at startup

This option allows you to choose whether you want your machine to automatically switch to a
graphical interface at boot. Obviously, you may want to select the No option if your machine is to
act as a server, or if you were not successful in getting the display configured.

Quit

If you modified your graphical display in some way, the current configuration will be displayed and
XFdrake will ask you whether you want to keep your changes or not. This is your last chance to go back
to the old configuration. If all seems OK, click on Yes. If you wish to restore the previous parameters, click
on No.

The changes will be activated after you confirm them and restart your graphical environment.

6.3. Configuring the 3D Desktop

This tool, accessible from the Hardware section of Mandriva Linux Control Center, lets you configure the
“3D desktop” for stunning visual effects on your desktop, together with a change from a flat desktop
to a cubic one.

Figure 6-5. Activating 3D Desktop Effects
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Activate the 3D Desktop

1. The first time you run Drak3D a few required packages may be installed; then you are presented with its
main window (see figure 6-5).

2. Select the Full 3D desktop effects (compiz) option to enable the 3D desktop. There are two approaches:
AIGLX and Xgl, Drak3D selects the most appropriate one for you according to your hardware.

3. Click Run compiz configuration tool to fully customize every single aspect of the 3D desktop support, a new
window appears for you to set all parameters to your liking.

About desktops: Once the 3D desktop is active, the number of virtual desktops as shown by the desktop manager
(KDE or GNOME) will be reduced to one. You now have instead viewports (the cube faces) for your virtual desktops,
explore and enjoy them!

4. Once you are satisfied with your settings, apply them by clicking Ok; they take effect the next time you
enter your graphical session.

Disable 3D. Select the No 3D desktop effects option to disable the 3D desktop completely, and return to your
“flat” desktop.

6.4. Changing your Keyboard Layout

This tool allows you to define another keyboard layout, useful when the keyboard you want
to use is different from the one chosen at installation time.

Figure 6-6. Choosing a Different Keyboard Layout

Select your keyboard’s language and then its model from the lists shown in figure 6-6. If you own a multimedia
keyboard and it is listed in the manufacturer list, chances are most multimedia keys on it will be supported.
Otherwise, choose your keyboard type under the Generic branch. Changes are effective immediately after
clicking OK.
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Note: If you choose a keyboard layout based on a non-Latin alphabet, the next dialog will ask you to choose the key
combination that will switch the keyboard configuration between the Latin and non-Latin layouts.

6.5. Changing your Mouse

This tool enables you to set up a different mouse, which is useful if the mouse you are currently
using is not the same as the one you chose at installation time.

Note: Synaptics Touchpad function is automatically configured to work with almost every touch pad found on notebook
computers. The same goes for Wacom® tablets.

Figure 6-7. Choosing a Different Mouse

Mice are sorted into a tree according to their connection type and model (see figure 6-7). Highlight the mouse
of your choice and click OK. Changes take effect immediately after the mouse test is done.

Tip: The Any PS/2 & USB mice option works with virtually all modern mice.

6.6. Configuring Printers with PrinterDrake

This tool allows you to:

• Configure a newly installed printer;

• configure your machine to act as a server for a printer connected to your local network;

• set up your machine to access network printers served by other servers.
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6.6.1. Automatic Installation

If you connect and power on a USB printer, a dialog pops up.

Figure 6-8. A new Printer was Detected

Deactivate Automatic Detection. If you don’t want the “automatic setup” popup to show again, check Do not
setup printer automatically again.

Then just click Ok, all required packages will be installed, and the printer configured for you to let you use it
right away: nothing else to do!

Configuration. It is however recommended that you check the printer default parameters, especially paper
size. To do this launch PrinterDrake from the Mandriva Linux Control Center and follow the instructions from
Reconfiguring an Existing Printer, page 78.

6.6.2. Manual Configuration

Tip: If you have just installed a printer that wasn’t available when you installed Mandriva Linux, make sure it is correctly
connected and powered on before launching the configuration tool.

When you first launch the PrinterDrake tool, it may be in one of these states:
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6.6.2.1. There is no printer directly connected to the computer.

Figure 6-9. Activate Printing

The tool did not detect any local printers. However you can print on network printers, or manually installed
printers which weren’t detected by clicking on Yes.

Figure 6-10. Activating Network Printers

• Select the Local CUPS printing system option if you wish to configure your machine to act as a print server
for either a local printer which was not detected, or a networked printer connected to your local network.

Any required software will be installed and then the main configuration interface (see figure 6-12) appears.
Click on Add Printer to install the network printer.

• Select the Remote server option if you wish to be able to print on printers served by another CUPS print
server on the network. Your applications will immediately have access to all public printers served by that
server. You only need to provide the hostname or IP address of that server in the field (ask your system
administrator).

When this is done, the main configuration interface (see figure 6-12) appears. The Configured on other machi-
nes tab will be filled with the available network printers.
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6.6.2.2. New Printer Detected

The following window appears when PrinterDrake detects a new printer at launch time.

Figure 6-11. A New Printer Is Detected

Simply confirm the automatic installation of the new printer. The main configuration interface (see figure 6-12)
is then displayed. Make sure you check that the printer parameters fit your needs (see Reconfiguring an Existing
Printer, page 78).

6.6.2.3. A Printer is Already Configured

The main configuration interface (see figure 6-12) is shown. Make sure that the printer parameters fit your
needs (see Reconfiguring an Existing Printer, page 78).

6.6.3. The Printer Management Interface

Local and Remote Printers. Use the printer configuration tool’s first tab for locally connected printers
(Configured on this machine), and the other tab for printers available on your local network (Configured on
other machines).
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Figure 6-12. Managing Printers

The following buttons give you access to all available maintenance tasks:

• Add Printer: launches the printer configuration wizard described in The Printer Configuration Wizard, page
77.

• Set as default: sets the selected printer as the default printer when no specific printer is chosen at print time.
A cross appears in the Def. column of that printer.

• Edit: opens the printer configuration dialog described in Reconfiguring an Existing Printer, page 78.

• Delete: removes the selected printer from the available printer pool.

• Refresh: updates the list of available printers, especially useful for networked printers.

• Configure CUPS: by default, your system is open. PrinterDrake uses all of the network’s available printers and
shares all of its local printers with the local network. Click on this button if you don’t want to access network
printers, or if you want to restrict the access to your local printers. This dialog also lets you configure access
to print servers outside the local network (see Print Server General Configuration, page 74).

Note: The Options→Expert mode menu adds extra features to the tool. See Expert Mode, page 80.

6.6.4. Print Server General Configuration

The Configure CUPS button allows you to control the behavior of printers connected to your machine and to
your network.
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Figure 6-13. CUPS Printer Server Configuration

This dialog enables you to switch between the client and server printing modes through the Remote CUPS
server and no local CUPS daemon button.

This button enables you to select between two remote server access methods.

In the first method your server must have a CUPS daemon running and be listening on port 631 in order
to manage the print queue and to listen for jobs coming in from applications. In this case the CUPS server
broadcasts its presence to the entire network. This is the default configuration.

In the second method, the CUPS daemon is still required to manage the queue and to handle jobs coming in
on port 631, but it does not broadcast its presence to the network. In this case the clients do not need to run a
CUPS daemon, instead they have a configuration file which contains the IP address of the server. In this way
the clients know they can sent jobs directly to the IP address.

Advantages Disadvantages

Method 1 No client configuration required Runs with at least one open port
and consumes extra machine
resources

Method 2 No local printing system. No open
ports

If the IP of the server changes or
the client changes to another
network, then reconfiguration is
required.

Table 6-1. Considerations
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6.6.4.1. Client Mode

Figure 6-14. Client Mode Configuration

Select the On option to connect to another printer server. Then you only need to specify the name or IP address
of that server in the next field below.

If you choose this mode, your printing configuration is now finished. Accept the options by clicking the OK
buttons, and you will be able to check the list of available printers in the Configured on other machines tab of
the main interface (see figure 6-12).

6.6.4.2. Server Mode

If you want your machine to access locally connected printers (through parallel or USB ports), or network
printers not already configured on another server, you need to select the Off option. Click OK to fine tune your
printer server (see figure 6-13).

A number of options are available to further secure and enhance your print server features:

The printers on this machine are available to other computers

Allows other computers to print on printers configured locally. Remember to restrict access by clicking
on Printer sharing on hosts/networks (see below).

Automatically find available printers on remote machines

Tells your print server to automatically make all printers found on other servers available to the local
network, as if they were locally connected to your print server. This way your system’s users are able to
print on any printer the print server can “see”. If the remote printers you intend to use are served by a
server not on your local network, you can still tell the print server to use them with the Additional CUPS
servers button (see below).

Printer sharing on hosts/networks

Allows you to specify from which networks the local printers are made available.

Additional CUPS servers

Allows you to specify one or more CUPS servers to which you can connect and access printers. Specify
the IP address and port of the CUPS server in the dialog.
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Japanese text printing mode

Replaces the original text filter for one more suited to Japanese texts, but with less features. Use it if you
have to print Japanese text-only files.

6.6.5. The Printer Configuration Wizard

Click on Add printer and the configuration wizard comes up.

6.6.5.1. Detect Printers or Specify Access Path

The first step serves to either specify an access address to a network printer, or to activate auto-detection of
locally connected printers, network printers, and finally printers served by SMB (Windows®) servers.

Figure 6-15. Printer Type

Specifying the Location. If you happen to know all parameters required to access a specific network printer,
select Enter host name/IP address of network printer. Configuration steps are then similar to the ones involved
in auto-detection procedure.

6.6.5.2. Choose the Printer

Figure 6-16. Detected Printers List

1. Choose the Printer to be Configured

Select the printer you want to add from the list of detected printers. If the detected printer isn’t the correct
one check the Manual configuration box and proceed with the printer model step. If autodetection fails,
remove the check mark from all check boxes, click on Next and follow the instructions below.
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2. Specifying the Driver Manually

PrinterDrake displays your printer’s model name. Choose Select model manually if it’s incorrect. Select the
printer you have or a compatible one (see Choose the Printer, page 77) if yours is not specifically listed.

3. Manufacturer-Supplied Driver

If you want to install the driver supplied by your printer manufacturer, click on the Install a manufacturer-
supplied PPD file button and select the medium containing the PPD file and browse to it. Accept subsequent
dialogs to use your chosen PPD file.

4. HP Multifunction Devices

If you own a multi-function device such as those of HP or Sony, an information window pops up and
gives you information about your scanner and scanner software (Installing and Sharing Scanners, page 80).
Additional required packages are also installed.

Fax Virtual Printer. If your device also provides fax functions, you are given an option to create a virtual
fax printer that will actually queue the printed documents so they can be later sent via fax.

5. Optional Configuration Step

If your printer has optional add-on devices (finishers, extra paper trays, etc.), you are asked which features
are actually installed.

6.6.5.3. Printer Test

Several test pages are available (see figure 6-17). We recommend you print at least one test page so you can
immediately correct the parameters if something is incorrect. The printer should begin to print almost imme-
diately.

Figure 6-17. Testing the Printer

6.6.5.4. It’s Done

If you’re not satisfied with your test page, answer the appropriate question with No and you will be led to the
printer configuration menu (see figure 6-18) where you can correct the settings. See Reconfiguring an Existing
Printer, page 78.

Your printer will now appear in the list of available printers in the main window (see figure 6-12).
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6.6.6. Reconfiguring an Existing Printer

Double-clicking on a printer’s name in the list, or clicking on the Edit button, displays a menu where you can
choose actions to take on the selected printer (figure 6-18). You can change the printer name, options, etc.

Figure 6-18. Modifying an Existing Printer

Here are some of the most useful entries:

• Printer name, description, location. If you have many printers around it is better to give them explicit names,
and meaningful descriptions, plus a location so people don’t end up looking desperately for their printouts
in many floors.

• Printer Options. Shows the different options available for that printer (paper size, printout mode, etc.), so
you can set a default value for them.

• Make this printer invisible for other computers. Printers are normally made available to other computers in the
local network. Using this option you can disable this behavior for the currently selected printer.

• Disable Printer. Use this option to remove a printer from those to the system’s users. You might need to
temporarily disable a printer under maintenance so that users don’t try to use it in the meantime. When a
printer is disabled, that option changes to Enable printer.

• Learn how to use this printer. Displays information on how to use a particular printer model. In the case of a
multi-function device from HP, additional information for the “extra” functions is also displayed.

• Remove printer. Deletes that printer’s configuration from the system.

Select an action in the dialog and then click on the Do it! button to perform it.

6.6.7. Controlling Automatic Installations

Open the Options→Configure Auto Administration menu to go to the automatic installation options form.
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Figure 6-19. Set Automatic Installation Options

You can here configure whether new printers should be automatically detected, automatically configured, etc.

6.6.8. Expert Mode

The expert mode activates additional features in the application.

More Technical Installation Wizard. The installation wizard displays more technical information and allows
you to configure printer name and other options directly from within the wizard.

Choose a Different Printer Driver. Different drivers are available for the same printer. In expert mode, a
third level appears in the printer model selection list (see Choose the Printer, page 77) letting you change each
printer’s driver.

No Automatic Configuration. If PrinterDrake is in expert mode, it doesn’t automatically configure new local
printers on start-up. Use the Add printer button to configure the printer. However you can choose to Configure
Auto Administration from the Options menu to override that behavior.

Automatic correction of CUPS configuration. This new option appears in the CUPS server configuration
window (figure 6-13. It is activated by default. Leave the mouse over the option name to get more information
about what it does.

6.7. Installing and Sharing Scanners

The ScannerDrake wizard helps you install your scanner. Make sure your scanner is powered
on and launch ScannerDrake by clicking on the Scanners entry of the Mandriva Linux Control
Center’s Hardware section.

Tip: Please note that not all scanners are supported under GNU/Linux. Before buying new hardware, remem-
ber to check out Mandriva’s Hardware Database (http://hcl.mandriva.com) and the SANE home page (http:
//www.sane-project.org/) for compatibility issues.
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6.7.1. Main Interface and Scanner Installation

The program tries to detect your scanner’s manufacturer and model. If it finds the scanner then information
about it is displayed in the upper part of the wizard’s main window. The window also offers a few action
buttons (figure 6-20).

Figure 6-20. Installing your Scanner

Search for new scanners

Click on this button to autodetect a new scanner you have just plugged in.

Add a scanner manually

Use this button if the automatic detection fails and then look for the specific model you own by browsing
through the list of available scanners and models.
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Figure 6-21. The Tree-list of All Known Scanner Models

Choose the right Port. After choosing the appropriate model, you can leave the default Auto-detect available
ports option unless you have a parallel port scanner, in which case selecting /dev/parport0 in the pull-down
list should be the right choice.

HP multi-function devices

Note that HP multi-function devices, such as the OfficeJet and PSC printers, must be configured through Printer-
Drake. Please refer to Configuring Printers with PrinterDrake, page 70. The scanning part of non-HP multi-function
devices can be set up with ScannerDrake as a stand-alone scanner.

6.7.2. Share your Scanner

ScannerDrake allows for scanner sharing between users connected via a LAN.
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Figure 6-22. Sharing Scanners within a LAN

Share Your Own Scanner

1. Check the The scanners on this machine are available to other computers box.

2. Click the Scanner sharing to hosts button and then Add host to specify which hosts will be actually allowed
to access your scanner.

Use Other People Scanners

1. Check the Use scanners on remote computers box.

2. Click the Use the scanners on hosts button and then Add host to specify which hosts serve the scanner you
wish to use.

6.8. Setting up your UPS

This tool will configure the NUT (Network UPS Tool) service for you. The service checks the UPS
connected to your machine and automatically shuts it down when the UPS is about to run out of battery
power.

Automatic Installation. Open the Mandriva Linux Control Center in the hardware section and click on Set up a
UPS for power monitoring to launch DrakUPS. Check the Connected through a serial port or a USB cable button
to let DrakUPS autodetect your UPS.

Manual Configuration (Serial Port)

1. Select the Manual configuration option.

2. Select your UPS from the list of manufacturers and models.
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3. Then assign a Name, Driver, and Port1.

If all went well your UPS should now be configured and ready to help avoid bad power outage surprises.

1. The Name and Driver fields should automatically be filled. Of course, you can change its name but we recommend you
keep the driver name.
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7.1. Network and Internet Connection Management

Tip: Before connecting to the Internet, you are encouraged to set up a firewall on your machine so as to avoid bad
surprises such as intrusions to your system. You can set up a very simple, yet effective, firewall using DrakFirewall. Please
refer to Securing your Internet Access via DrakFirewall , page 109 for more information.

The drakconnect set of tools allows you to easily configure your network access, whether it be to the Internet
or to a local network. Open Mandriva Linux Control Center and select the Network & Internet section to access
drakconnect tools. A view of the main interface is shown in figure 7-1.

Figure 7-1. DrakConnect Tools

7.1.1. Set Up a New Network Interface

drakconnect supports different types of Internet and network connections. The first step consists
of choosing which type of connection you wish to configure. Always make sure you have all the
information provided by your ISP or network administrator at hand.

Note: After a connection has been configured it can be further modified using the Connections management interface
(see Reconfigure Interfaces, page 88).

7.1.1.1. Wired Ethernet Connection

1. Select the Ethernet type

Your NICs are detected automatically; if you have more than one, you have to select the one you wish to
configure. You can also load a driver for your NIC manually.
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2. Automatic or Static Configuration

You now have to specify whether the network parameters are automatically set up (Automatic IP
(BOOTP/DHCP)) or not (Manual configuration): fill the next steps with the parameters which your ISP
or network administrator gave you.

3. Connection Control

Allow users to manage the connection

If you wish users to be able to bring up or shutdown the connection without having to provide the
root password (see Monitoring Connections, page 89) check this box.

Start the connection at boot

Uncheck this if you want the connection to be activated on demand only.

The Net Applet: An applet appears in the desktop’s panel indicating that the connection is up

or down

. Right click on it to access a menu that will also let you control the connection’s state as well as other parameters.

7.1.1.2. Wireless Connection

This entry allows you to configure WiFi PCMCIA or PCI devices.

1. Choose WiFi Card

If your card is not listed, choose the Use a Windows driver entry. The next step then asks you to select the
driver from the manufacturer’s card drivers CD.

2. Choose Network

A list of detected networks is then shown. Select yours, or unlisted otherwise.

3. Wireless Settings

Operating Mode

The mode the card will operate on, with respect to the other WiFi devices in the network. The most
common one is Managed to simply connect to an existing access point.

Network Name (ESSID)

The name of the network you wish to connect to. Ask your network administrator.

Encryption Mode

This depends on the network settings, ask your network administrator.

Encryption key

This also depends on the network settings, ask your network administrator for the key the network
uses.

4. Network Configuration

This is now similar to the traditional ethernet network setup: Wired Ethernet Connection, page 85.

5. Connection Control

Check the Allow access point roaming box if you wish the connection to automatically switch from one
access point to another, depending on the signal strength of it. Particularly useful when moving a laptop
around.

Managing Connections. Consult Wireless Connections Management (Roaming), page 91 to learn how to configu-
re and manage various wireless networks.
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7.1.1.3. ISDN Connection

Simply make sure you select the right parameters in all steps, concerning your area and provider.

The last step gives you the option to handle the connection status through the net applet, this can prove useful
if you only need the Internet connection from time to time.

7.1.1.4. Modem Connection (POTS)

1. A list of detected modems is shown. If no modem was detected then only the Manual choice option is
shown, click on Next and choose the communications port the modem is connected to. The required pac-
kages are installed.

2. You then see a list of countries/ISPs. If yours is listed select it and continue to the next step: some para-
meters (connection name, phone number to dial, and authentication scheme) will be automatically set. If
not, select the Unlisted - edit manually option.

3. Verify the parameters, add the missing ones provided by your ISP.

Figure 7-2. Entering Dial-up Connection Parameters

All parameters should be obvious, except for the authentication type. The value in the Authentication
pull-down depends on what your ISP supports: Script-based (an old type of authentication method based
on “expect” and “send” types of chat between your system and your ISP); Terminal based (a terminal
window will pop up when the connection is made and you will have to login interactively); PAP, CHAP, or
PAP/CHAP (authentication information exchange protocols, CHAP is preferred because it is more secure,
PAP/CHAP will automatically choose the supported one).

4. Then come the IP, DNS and gateway settings. Nowadays, most ISPs provide them automatically when a
connection is made, so selecting the Automatic option on them is usually a safe bet.

5. Connection Control

Allow users to manage the connection

You are then asked whether you wish to allow users to start the connection. That will allow them to
do so without needing the root password.

Start the connection at boot

It is probably safer and cheaper to choose No.

6. Finally you are asked to test the connection: we recommend you to do so to make sure all parameters are
accurate. You can now control your Internet connection using the net applet. You can also use the kppp
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remote access connection dialer (package kppp) by choosing Internet+Remote Access→KPPP from the main
menu.

7.1.1.5. DVB Connection

This connection type is used for satellite connections.

1. Choose the connection card you wish to configure, and then the adapter settings.

2. Network configuration is then similar to the LAN connection type (see Wired Ethernet Connection, page
85).

7.1.1.6. GPRS/Edge/3G

This connection type supports Internet connections through cellular phone networks, accessed through a
PCMCIA card. Third generation (3G) technologies, as well as older ones (GPRS/Edge) are supported. Support
for newest HSDPA norm is also available.

7.1.2. Internet Settings

Figure 7-3. Configuring the Internet Access

This tool allows you to specify Internet access parameters if they need to be modified after your
initial configuration. Please bear in mind that these parameters are system-wide and apply to all
interfaces. To change the gateway address see Reconfigure Interfaces, page 88.
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7.1.3. Reconfigure Interfaces

Figure 7-4. Manage Network Connections

This tool permits you to modify network interface-specific parameters, after you have set them
up through the new interface wizard (see Set Up a New Network Interface, page 85). Use the drop-
down list at the top to select the interface you want to configure. The tabs allow you to change
parameters and options according to the network interface type selected.

7.1.4. Monitoring Connections

Figure 7-5. Real-Time Network Connection Monitoring
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This tool shows the network interfaces activity. You can specify some options for the traffic graphic
and statistics: update interval, scale, etc (see figure 7-5). It can also be used to control the status of
the network connection, bringing it up or down using the button at the lower left.

Note: The network monitoring interface can be brought up by users through the net applet to monitor traffic.

7.1.5. Removing a Connection

This tool simply allows you to remove a network interface. Select the interface to be removed in
the Net Device pull-down list.

Warning

You will not be asked for confirmation. Once an interface is selected for removal, pressing the Next button deletes
it immediately.

7.1.6. Proxy Settings

If your Internet connections must (or can) pass through a proxy, this tool allows you to define
the hostnames or IP addresses of proxies for the FTP and HTTP protocols. Fill the fields with the
required values and click OK.

What’s a Proxy. A proxy is a server which retrieves information from the Internet on your behalf, keeping a
local copy of the web pages which are most frequently requested. They are referred to as “caching proxies”,
and optimize bandwidth usage. In some organizations, you cannot access the Internet directly. You must pass
through a proxy which authenticates you before allowing you to connect to the Internet. This is usually com-
bined with a firewall which only guarantees the proxy direct access to the Internet. They are referred to as
“authentication proxies”. In corporate or business environments, proxies perform both caching and authenti-
cation functions for performance and security reasons.

7.2. Activating and Managing Network Profiles

Mandriva Linux Control Center profiles enable you to store different configuration sets for your machi-
ne, for example for different locations. This is especially useful for laptops which need a different
configuration for home, at the office, the coffee shop, etc. The parameters that can change from one

profile to another are:

Network Configuration

Activate different interfaces, with different configuration, for wireless for example.

Services Configuration

Allows you to activate different services from one profile to another, for example a firewall at home and
no firewall at the office (see Configuring Start-Up Services, page 95).

7.2.1. Profile Handling

New profiles you wish to create are based on the active one. All modifications are automatically recorded in
the active profile. A single menu (Profiles) lets you manage them.
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Figure 7-6. The Control Center Profiles Interface

Activate

Make the selected profile active.

Clone

Creates a new profile based on the selected one’s settings. A dialog pops up asking for the name of the
new profile. Don’t forget to activate that profile after creating it if you wish to configure it.

Delete

Deletes the currently selected profile, without further prompts. Please note that a warning is shown if you
try to delete the active profile, because it cannot be removed while being used.

The default Profile. This is the profile that will be used at boot time. It cannot be deleted.

Example: Create a New Profile for your Dial-up Home Connection. You come back home with your brand
new laptop which your system administrator configured so you can connect to your corporate network. You
now want to configure the network to access the Internet from home with a dial-up connection.

1. Create a new profile called “Home”.

2. Switch to it.

3. Reconfigure your network so that the modem, instead of the network card, is used to access the Internet
(see Network and Internet Connection Management, page 85).

4. Connect to the Internet.

5. When back at the office, switch back to the “default” profile.

7.3. Wireless Connections Management (Roaming)

This tool shows the wireless networks currently available and allows you to switch between them,
and to change their configurations. If you haven’t configured your wireless interface yet, please
refer to Wireless Connection, page 86 for information. figure 7-7 shows DrakRoam’s interface: a list
of the available networks, together with their status, and buttons for actions at the bottom.

Tip:

You can also right click on the “signal meter” icon in the panel and choose Manage wireless networks, then
enter root’s password, to access the tool.
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Figure 7-7. DrakRoam Interface

7.3.1. Switching Networks

To change networks, select one of those from the list, then click on Connect. If the network is public you will
be immediately connected. If the network is private, then you are asked for configuration parameters with the
same dialog shown in figure 7-8. Provide required settings (in particular, the encryption key) and click Ok.
Settings take effect immediately.

7.3.2. Configuring a Wireless Connection

If you need to change the network parameters, just select the network from the list, then click on Configure.
See figure 7-8 for an example of a secured wireless network connection.
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Figure 7-8. Changing Wireless Network Configuration

Make your adjustments and click Ok, the settings take effect immediately.
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8.1. Configuring Start-Up Services

At boot time, the system starts a number of services (programs which run in the background
to perform a variety of tasks). This tool gives the administrator control over those services. See
the The Start-Up Files: init sysv chapter of the Reference Manual for more information.

Figure 8-1. Choosing the Services Available at Boot Time

For each service, this is the list of items found in each column:

• Service name;

• Current Status: either running or stopped;

• Info: click on this button to get a little explanation about that service;

• On Boot: check this box if you wish this service to be automatically started at boot time1. Alternatively,
if xinetd is installed and the service is a xinetd service, the label Start when requested will be displayed.
Checking the box will then mean to activate that service in xinetd. You will also have to make sure that the
xinetd service itself is activated.

• Start: immediately starts the service, or restarts it (stop+start) if it is already running;

• Stop: immediately stops the service.

After pressing the Start or Stop buttons, a tool tip shows you the status of the operation.

1. Generally in runlevels 3 and 5.

95



Chapter 8. Managing your Users, Menus and Services

8.2. Managing Fonts on your System with DrakFont

This system sdministration tool enables you to review the different font families, styles, and
sizes available on your system. It also allows for fonts to installed or removed.

The main window (see figure 8-2) shows a visual appearance of the currently selected font combination.

Figure 8-2. DrakFont’s Main Window

drakfont is made up of a number of dialogs which are accessible through the buttons located at the bottom.

Get Windows Fonts

This button automatically adds fonts found on your Windows® partitions, if any, of your local hard drives.

Options

Allows you to specify which applications and devices (such as printers) will support the fonts. Select the
ones you want support for and click on the OK button.

Uninstall

Allows you to remove installed fonts, in order to save space for example. Use this with great care, it could
have side effects for your applications. In particular you should not remove fonts you did not install
yourself.

This actually removes all fonts found in a given directory. Note that fonts manually added through drak-
font are found in /usr/share/fonts/drakfont/

Import

Allows you to manually add fonts found outside the Mandriva Linux distribution, from a fonts disk you
have purchased or from the Internet, for example. Supported font types are ttf, pfa, pfb, pcf, pfm,
gsf. Clicking on the Add button will open a standard dialog allowing you to specify the font file to
import. Once you’ve specified all the fonts you want to import, click on the Install fonts button.

Selecting more than one font: To select more than one font, press the CTRL key while selecting the fonts you
want to install and click OK, they will be added to the Import Fonts window. Then, click on the Install fonts button.
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Note: When adding or removing fonts, the change might not appear immediately in the fonts list. Close and re-launch
drakfont to ensure your changes were taken into account.

8.3. Setting your Machine’s Date and Time

This little tool enables you to set your system’s correct internal date and time.

Figure 8-3. Changing Date and Time

You can set the date on the left and the time on the right:

1. Date

To change the year, click on the little arrows on each side of the year; same procedure to change the month.
This updates the month view where you can click on the current day in order to highlight it.

2. Time Zone

We recommend that you check the time-zone settings for your geographical location. Click on the Change
Time Zone button and select the correct place in the tree view.

Once you’ve chosen the time zone, a dialog appears asking you whether your hardware clock is set to
GMT. Answer Yes if only GNU/Linux is installed on your machine, No otherwise.

3. Time

To change the time, you can either move the hour, minute and second hands of the analog clock, or change
the numbers below it.

4. Automatic Clock Synchronization

97



Chapter 8. Managing your Users, Menus and Services

If you have a permanent Internet connection and want your system to synchronize its internal clock with
time servers on the Internet, put a check mark in the Enable Network Time Protocol option and select a
server in the Server pull-down list, preferably one near you. If you know the name or the IP address of a
local server you can also enter it manually in that field.

When you’re finished, click on OK to apply your settings or Cancel to close the tool, which will discard your
changes. If you want to return to your previous settings, click on Reset.

8.4. Monitoring System Activity and Status

This tool allows you to look for specific entries in various log files, therefore making it easier to
search for particular incidents or security threats.

8.4.1. Browsing System Logs

Figure 8-4. Browsing and Searching through System Logs

These are the steps to follow in order to browse or look for a specific event into the system logs:

1. Matching Terms

You must choose which specific words to match by filling the Matching (log files contain the words) field
and/or the but not matching (log files which don’t contain the words) field. At least one of the two fields
must be filled.

2. Log File
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Then in the Choose file area select the file you want to perform the search on. Simply check the correspon-
ding box.

Note: The Mandriva Linux Tools Log is filled by Mandriva Linux-specific configuration tools, like those you find in
the Mandriva Linux Control Center. Each time these tools modify the system configuration they write to this log
file.

3. Date of Event

Optionally, you can restrict the search to a specific day. In that case, check the Show only for the selected
day box and choose the desired day from the calendar.

4. Search

When all is set up, click on the Search button. The results appear in the Content of the file area at the bottom.

Clicking on the Save button opens a standard dialog letting you save the search results into a plain text (*.txt)
file.

8.5. Managing Users and Groups

UserDrake allows system administrators to easily add and remove users from the system, to assign users to a
group, and to manage user groups in the same manner.

Note: In this section we will only focus on user management. Group management being similar.

8.5.1. The Interface

Launching UserDrake will display the main window (figure 8-5) which lists the users currently defined on the
system. You can switch from users to groups by clicking on the Groups tab next to the Users tab.

Figure 8-5. The User List in UserDrake

All changes have immediate effect on your local user database. If the user list is modified outside of UserDrake,
you can refresh UserDrake’s window by clicking on the Refresh button.

Note: If you make changes to an already logged in user, those changes won’t take effect until the next time he or she
logs in again.

Available actions are:
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Add User

Adds a new user to the system. We will detail this procedure in Adding a New User, page 100.

Add Group

Adds a new user group to the system.

Edit

Allows you to change the parameters of the selected user or group. We will detail editing user parameters
in Adding a New User, page 100. In the case of a group you will be able to assign or remove users from that
group.

Delete

Removes the selected user or group from the system. A confirmation dialog will be shown, and in the
case of a user you will also be able to remove the user’s /home directory and mailbox.

8.5.2. Adding a New User

We created the non-privileged user Queen Pingusa at installation time, and now we want to create a new user
called Peter Pingus. Then we want to make them both members of the fileshare group, so that they can
share folders with other users on the network .

Click on the Add User button, a dialog box to add a new user will pop up (see figure 8-6). The only required
field is Login although we strongly recommend that you set up a password for this new user: enter it in both
the Password and Confirm Password fields. You can also choose to add a comment in Full Name. Generally, this
is the full name of the user, but you can put whatever you want.

Figure 8-6. Adding a New User in the System

We now have two users in our list. Select one of them with your mouse, and click on the Edit button. The
dialog box shown in figure 8-7 will pop up. It allows you to modify most available user parameters.
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Figure 8-7. Adding Users to a Group

The dialog is made of the following tabs:

User Data

Allows you to modify information provided when the user was created.

Account Info

Enables you to provide an expiration date for that account, after which the user won’t be able to connect
to the system. This is useful for temporary accounts. It’s also possible to temporarily lock an account to
prevent a user from logging in. Finally, this tab allows you to change the icon associated with the user.

Password Info

Allows you to provide a password expiration date, after which the user will be required to change his
password.

Groups

Shows the list of available groups where you can select the groups to which any user should belong.

For our users we just need to look for the fileshare entry and check the box associated to it. Then click on
the OK button to make the changes effective.

8.6. Backing Up and Restoring your Files

This tool allows you to back up data present on your computer onto different media and also
to a remote machine over a network. It also supports multiple profiles for different backup
scenarios. Once the parameters are set, you can run the backup periodically. Then, you can
forget about it until you wish or need to restore files.

8.6.1. A Practical Example Using the Wizard

You can access this tool by clicking on the Backups icon in Mandriva Linux Control Center’s System section. Click
on the Wizard Configuration button to start the wizard. After making your choices in each step click on Next.
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8.6.1.1. First Step: What to Backup

Figure 8-8. Selecting What to Backup

Select Backup System to include the /etc directory where all your current system configuration files lie. This
allows you to “transport” your system to a different computer with little effort: only hardware-dependent
configuration will have to be revised.

Note: The“system”backup does not include applications themselves (i.e. executable files, libraries). A priori this makes
sense because it is likely that you will have access to the system’s installation media from which applications can be easily
installed again on the target computer.

Select Backup Users to include all the files included in all of your users’ /home directories. Clicking on the Select
user manually button lets you select individual users and give you the following options:

• Do not include the browser cache. Selecting this option is recommended due to the very nature of the ever-
changing browser cache.

• Use Incremental/Differential Backups. Selecting this will preserve old backups. Choosing Use Incremental Bac-
kups will only save files which have been changed or added since the last backup operation. Choosing Use
Differential Backups will only save files which have been changed or added since the first backup operation
(also known as the “base” backup). This last option takes more space than the first one, but allows you to
restore the system “as it was” at any given point in time for which a differential backup was made.

102



Chapter 8. Managing your Users, Menus and Services

8.6.1.2. Second Step: Where to Store the Backup

Figure 8-9. Selecting Where to Store the Backup

All possible backup media are listed, along with a Configure button to change media-dependent options:

Hard Disk Drive

The local hard disk drive is used to prepare backups for all media except NFS and direct to tape. You
should not perform backups on your local hard disk anyway, you should always backup on remote or
removable media. You can set the directory for storage and the limit of storage space. You can also set
how many days to keep incremental or differential backups in order to save disk space.

Across the Network

To store the backup on a remote computer accessible using different methods. You can set the connection
parameters as well as the access method and its options (if applicable). Please note that NFS backups are
considered to be local disk backups, even if they are effectively stored on a remote system.

On Tape

You can set the tape device if it’s not detected automatically, and tape parameters such as writing directly
on tape, whether or not to rewind, erase and eject the tape.

Optical Media (CD-R)

This is our preferred media for the example, so click on its Configure button to set the required parameters
(see figure 8-10).
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Figure 8-10. Setting Optical Media Parameters

If it isn’t done automatically, use the Choose your CD/DVD device combo box to set the CD/DVD device. Set
the medium’s type and size, multisession and erasing options.

For multisession recordings, please bear in mind that the option to erase the medium is only effective for the
1st session and also that session-related information recording takes some space out (20 to 30 MB) for each
session, so the “real data” storage space will actually be less than the medium’s size.

8.6.1.3. Third Step: Review and Store the Configuration

Figure 8-11. Review Configuration Parameters

104



Chapter 8. Managing your Users, Menus and Services

The last wizard step shows a summary of the configuration parameters. Use the Previous button to change any
parameter you are not satisfied with. Click on Save to store them on the Default profile. The backup set is
now ready to be performed.

Backup Profiles

You can choose File→Save profile as from the menu and provide a profile name to store the current backup
settings within a named backup profile. You can then run the configuration wizard again, define other settings
and store them under a different profile.

Use the --profile Profile_Name.conf option when you run Drakbackup from the command line to load
the Profile_Name.conf profile.

8.6.1.4. Performing the Backup

Click on Backup Now, make sure the corresponding media is ready (the recordable CDs in our example), and
then on Backup Now from configuration file to perform the backup.

Warning

If the backup set size exceeds the medium’s available capacity, the backup operation might just fail. This is a known
issue and it’s being worked on. As a work-around, please try to remove files from the backup set so its size never
exceeds the medium’s available capacity.

A dialog will display the current progress of the operation. Please be patient: the time it takes to back up
depends on many factors such as the size of the backup file set, the speed of the storage option selected,
and so on. Once the operation is finished a report is shown: look for possible errors on it and take corrective
measures if needed.

8.6.2. Restoring Backups

Figure 8-12. Choosing the Restore Type to Perform
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Make sure the media you want to restore the backup from is accessible and ready and click on the Restore
button. In our example we restore the whole backup so on the restore dialog (figure 8-12) click on Restore all
backups and then on the Restore button to start the restoration process.

Warning

Existing files in the target restoration directory (same location where the backup was made from, by default) will
be overwritten.

Feel free to investigate the other restore options if you want to restore part of a backup instead of the full file
set, or to restore the backup to a different location.

8.6.3. Automating Periodic Backups

In the tool’s main window, click on Advanced Configuration and then on the When button. In the backup sche-
duling window (see figure 8-13) select Use daemon to define the schedule.

Figure 8-13. Daemon Options Window

You are then asked to specify the interval (or period) between each backup operation and the storage media. In
our example we set up a customized calendar (custom period selected) to perform a backup from Wednesday
to Friday at a quarter to midnight and store it on CD, using the Default backup profile.

8.6.4. Advanced Backup Wizard Configuration

Click on Advanced Configuration and then on the More Options button to set more backup options (see figure
8-14).

106



Chapter 8. Managing your Users, Menus and Services

Figure 8-14. Miscellaneous Options Window

Archiving Program

You can choose between tar (the default) and star which allows you to backup extended ACLs too.

Compression Type

You can choose the compression strategy used for your backups among tar (no compression), tar.gz
(gzip compression) and tar.bz2 (bzip2 compression: better but slower).

Files to Ignore

You can exclude certain files from the backup. The .backupignore file should be present in every directory
of the backup file set where files are to be excluded. Its syntax is very simple: a one-file-per-line list of the
names of the files to exclude.

Tip: You can use the star (* = “matches any string”) and the question mark (? = “matches one and only one
character, regardless of what that character is”) in the .backupignore file to exclude sets of files. For example,
somename* matches all files whose names start with somename, and image00?.jpg matches files named
image001.jpg, image009.jpg, image00a.jpg, image00h.jpg, etc.

Send Reports by Email

Fill the mail address to which a report of the operation will be sent. You can specify many mail addresses
separating each with a comma (,). Please complete also the Return address for sent mail field with the email
address of the backups administrator, and the SMTP server for mail field with the name or IP address of
the outgoing mail server.

Delete Temporary Files

Select the Delete Hard Drive tar files after backup to other media option to free that space after performing
the backup.
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View Restore Log

You can choose to view the restore operation log after each restore. This can be handy to spot and fix
potential problems when restoring files: reading errors, network communications errors, etc.
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9.1. Securing your Internet Access via DrakFirewall

This little tool allows you to set up a basic firewall on your machine. It filters connection at-
tempts made from the outside, and blocks unauthorized ones. It’s a good idea to run it just
after installing your machine and before connecting to the Internet, therefore minimizing the
risks of your machine being ccompromised.

This Wizard consists of the three steps we detail below.

9.1.1. Choose Services to be Available from Outside

Figure 9-1. The DrakFirewall Window

Open Up Ports, If Needed. If checked, uncheck the Everything (no firewall) box, and then check the boxes
corresponding to the services you wish to make available to the outside world. If you wish to authorize a
service which isn’t listed here, click on Advanced to manually enter the port numbers to open.

Opening Unusual Services: The Advanced button opens a field named Other ports where you can enter any port to
be opened to the outside world. Examples of port specifications are presented just above the input field: use them as a
guide. It’s possible to specify port ranges by using the : syntax such as 24300:24350/udp.

This Won’t Block You from Accessing the Net. Not checking a service in this list won’t stop you from con-
necting to it. It will only prevent people from the Internet connecting to that service on your machine. If you
don’t plan on hosting any services on your machine (common case for a desktop machine) just leave all boxes
unchecked.

How to Disable the Firewall. On the other hand if you wish to disable the firewall and leave all services
accessible from the outside, check Everything (no firewall), but please bear in mind that this is very insecure,
and therefore not recommended.
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9.1.2. Activate Interactive Firewall Feature

Figure 9-2. Interactive Firewall Options

Stay Informed of Connections on your Machine.

The interactive firewall can warn you of connection attempts on your machine by displaying alert popups
through the network applet. Check the Use Interactive Firewall option to activate this feature.

Port scan detection

Activate this option to be warned of malicious attempts to access your machine.

Other entries corresponding to open ports

Next you are shown a checkbox for each port you have chosen to open during the previous step. Activa-
ting them will popup a warning each time a connection attempt is made on those ports.

9.1.3. Which Interface to Protect

The next step consists of selecting the network interface connected to the Internet.
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Figure 9-3. The Internet Interface

If you don’t know which interfaces you have connected for the Internet, you can check the system network
configuration (see Reconfigure Interfaces, page 88). You can finally click OK to install the required packages,
activate the firewall and enjoy your secure Internet connection.
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Mandriva’s convenient update service warns you about bug or security fixes specifically available for your
machines. This service can also be configured to automatically install package updates so you don’t have to
run it manually.

The system is comprised of the following items:

Initial Configuration Wizard (see Initial Configuration, page 113)

Enables you to register a new machine.

Web Management Interface (see The Web Management Interface, page 114)

Allows you to manage all the hosts you maintain and to activate hosts so they are taken into account for
updates.

Applet (see Mandriva Online Applet, page 116)

Informs you on the status of your updates, and allows you to launch the installation of updates when
needed.

Take a look at the Mandriva Online FAQ (https://www.mandrivaonline.com/page.php?page=info) page to
get further information about the Mandriva Online service.

10.1. Initial Configuration

The Mandriva Online wizard shows up when you boot your machine for the first time. It allows you to create a
new account or to register an existing one. To manually launch the wizard from your user account, right-click
on the Mandriva Online applet icon on the panel and choose Configure Now!. You will have to provide root’s
password.

Figure 10-1. Existing or New Mandriva Online Account?

After clicking on Next, select the appropriate option (I already have an account or I want to subscribe) and click
Next.
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Figure 10-2. Authentication on Mandriva Online

Enter your login information and provide a name to identify your machine. This is useful if you manage
several computers with Mandriva Online.

The next step explains what information is collected on your computer. This information is required for the
service to work correctly.

Figure 10-3. Uploading Your Configuration

Finally, choose your country so that automatic updates occur from the nearest possible server. If your country
is not listed, select the nearest one. Click on Next and Finish to exit the wizard.

Note: To complete your setup, you must activate this machine in your Mandriva Online account.
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10.2. The Web Management Interface

To activate your Mandriva Online account, access the Mandriva Online web administration interface (https:
//www.mandrivaonline.com/) by right-clicking on the Mandriva Online applet on the panel, and choose Online
WebSite. Once you’re on the website, provide your Mandriva Online email address and password.

Note: At this point, you can check out your mandriva account (https://my.mandriva.com) settings on the My Mandriva
Web site.

10.2.1. Subscribing New Machines

Figure 10-4. Mandriva Online Hosts List

10.2.2. Host Management

Once you activate a host you can access its management interface by clicking on the details icon.

Figure 10-5. Up-To-Date Mandriva Online Host

The available actions differ slightly according to whether your machine’s packages are up-to-date or not, but
basically here are the actions you can perform:

Control email alerts

Change the mail-sending status to yes (by clicking on the link) to receive an email when updates are
available.

Control automatic scheduled updates

Change the auto-update status to yes (by clicking on the link) to have updates for your machine auto-
matically installed by the applet (see Mandriva Online Applet, page 116) which regularly connects to the
Internet to check for such updates.
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Check current packages

Click on the See link by the Installed packages or Errata(s) label.

10.2.3. Scheduling Updates

You can update your machine manually from the applet (see Mandriva Online Applet, page 116); from the Web
interface, you can check which updates are available and choose which ones to install.

Figure 10-6. Outdated Mandriva Online Host

You must now select the packages to be updated. You can either schedule all packages to be updated, or choose
them one by one by clicking on the See link in the Outdated packages field.

Figure 10-7. Select Packages to be Updated

Click on the advisory link (of the MDKA-year:number or MDKSA-year:number forms) to obtain details
about that update. Check the box for each package you want to be updated on your machine. When this is
done, click on Schedule Packages.

Once updates are selected, they are automatically installed next time the applet connects to the Mandriva Online
server, which occurs several times a day.
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10.3. Mandriva Online Applet

The applet resides on your desktop panel. It informs you about update availability and allows you to perform
basic system maintenance tasks.

The applet icon can be in one of many states, depending on your machine’s status:

The system is up-to-date. All is fine.

A standard program update is available for your installed packages.

A bugfix update is available for your installed packages.

A security update is available for your installed packages. It is highly recommended that you
install security updates.

The applet is currently contacting the server, be patient.

This host isn’t currently activated. Activate it using the Web interface (see Subscribing New
Machines, page 115).

The applet cannot connect to the server. Check your Internet connection.

The system is currently not configured or a configuration error was found. Launch the
configuration wizard (see Initial Configuration, page 113) to use Mandriva Online.

Click on the applet icon to open a dialog with action buttons, followed by the current machine’s status.

Figure 10-8. Mandriva Online Applet

Install updates

Manually launch the updates installer by opening Rpmdrake (see Adding, Removing and Updating Software,
page 58).

Configure

Launch the wizard (see Initial Configuration, page 113). This can be useful to resend your machine confi-
guration to the server, for example if you have upgraded your hardware.

Check updates

Manually connects to the server to check if updates are available. This is done periodically by the applet,
but if you have no permanent connection to the Internet, it may be useful to manually check for updates
when you are online.

117



Chapter 10. Mandriva Online Services

118


	Getting Started
	Table of Contents
	List of Tables
	Preface
	1. About Mandriva Linux
	1.1. Contacting the Mandriva Linux Community
	1.2. Join the Club!
	1.3. Subscribing to Mandriva Online
	1.4. Purchasing Mandriva Products
	1.5. Mandriva Kiosk
	1.6. Contributing to Mandriva Linux

	2. About this Quick Start Guide
	3. Starting the MandrivaOne Live CD
	3.1. Booting the CD
	3.2. Default User Paswords


	Chapter 1. Exploring your New Environment
	1.1. Using the Internet
	1.1.1. Sending and Receiving Emails
	1.1.1.1. Mail Configuration
	1.1.1.2. Mail Client Interface
	1.1.1.3. KMail Usage

	1.1.2. Browsing the Web
	1.1.2.1. Browser Interface
	1.1.2.2. Surfing the Web

	1.1.3. Chatting With Friends and Colleagues
	1.1.3.1. Configuring Kopete
	1.1.3.2. Kopete Interface
	1.1.3.3. Chatting and IM With Kopete


	1.2. Doing Office Work
	1.2.1. Writing Documents
	1.2.1.1. Word Processor Interface
	1.2.1.2. Styles
	1.2.1.3. Lists
	1.2.1.4. Page Headers and Footers
	1.2.1.5. Going Further

	1.2.2. Calculations and Simulations
	1.2.2.1. Spreadsheet Interface
	1.2.2.2. Entering Data
	1.2.2.3. Adding Formulas
	1.2.2.4. Charts: Explaining Data in a Simpler Way
	1.2.2.5. Going Further

	1.2.3. Communicating your Ideas
	1.2.3.1. Presentations Interface
	1.2.3.2. Adding Slides to your Presentation
	1.2.3.3. Simple Charts
	1.2.3.4. Slide Background
	1.2.3.5. Transitions, Animations and Effects
	1.2.3.6. Running your Presentation
	1.2.3.7. Going Further


	1.3. Multimedia
	1.3.1. Playing Music
	1.3.1.1. Audio CDs
	1.3.1.2. Audio Files

	1.3.2. CD/DVD Burning
	1.3.2.1. Burning a Set of Files or Directories
	1.3.2.2. Burning Audio CDs (CDDA)

	1.3.3. Playing Movies
	1.3.3.1. Video Files
	1.3.3.2. DVDs

	1.3.4. Digital Photo Studio
	1.3.4.1. Building a Photo Album
	1.3.4.2. Rotating Pictures
	1.3.4.3. TouchingUp Pictures



	Chapter 2. Installing and Configuring your Peripherals
	2.1. The Mandriva Linux Control Center
	2.2. Setup your Printer
	2.2.1. Installing a Printer
	2.2.2. Configuring a Printer
	2.2.3. Testing a Printer

	2.3. Setup your Scanner
	2.3.1. Installing a Scanner
	2.3.2. Testing a Scanner

	2.4. Setup your Webcam
	2.4.1. Automated Webcam Installation
	2.4.2. Testing a Webcam

	2.5. Use your Digital Camera
	2.5.1. Transfer and Process Images with Digikam

	2.6. Memory Card Readers

	Chapter 3. Playing Around
	3.1. Free Linux Games
	3.1.1. Frozen Bubble
	3.1.2. Supertux
	3.1.3. XMoto
	3.1.4. KDE Cute Games
	3.1.5. StepMania

	3.2. Run Windows® Games on Mandriva Linux
	3.3. More Games

	Chapter 4. Share and Install your Linux System
	4.1. Live Copy
	4.2. Live Install
	4.2.1. Copy Files to Hard Disk
	4.2.2. System Configuration
	4.2.2.1. Networking
	4.2.2.2. Root Password
	4.2.2.3. Create User Accounts
	4.2.2.4. Registration Wizard



	Chapter 5. Package Management
	5.1. Adding, Removing and Updating Software
	5.2. The Software Media Manager
	Use check boxes of the lefthand columns to flag the repositories
	Action Buttons on the Right



	Chapter 6. Configuring your Hardware and Devices
	6.1. Configuring your Hardware
	6.1.1. Hardware Detection and Configuration
	6.1.1.1. What Is HardDrake?
	6.1.1.2. Usage

	6.1.2. Problems/Troubleshooting

	6.2. Controlling the Graphical Configuration
	6.2.1. Changing the Monitor
	6.2.2. Changing Resolution
	6.2.3. Controlling All Video Parameters

	6.3. Configuring the 3D Desktop
	6.4. Changing your Keyboard Layout
	6.5. Changing your Mouse
	6.6. Configuring Printers with PrinterDrake
	6.6.1. Automatic Installation
	6.6.2. Manual Configuration
	6.6.2.1. There is no printer directly connected to the computer.
	6.6.2.2. New Printer Detected
	6.6.2.3. A Printer is Already Configured

	6.6.3. The Printer Management Interface
	6.6.4. Print Server General Configuration
	6.6.4.1. Client Mode
	6.6.4.2. Server Mode

	6.6.5. The Printer Configuration Wizard
	6.6.5.1. Detect Printers or Specify Access Path
	6.6.5.2. Choose the Printer
	6.6.5.3. Printer Test
	6.6.5.4. It's Done

	6.6.6. Reconfiguring an Existing Printer
	6.6.7. Controlling Automatic Installations
	6.6.8. Expert Mode

	6.7. Installing and Sharing Scanners
	6.7.1. Main Interface and Scanner Installation
	6.7.2. Share your Scanner

	6.8. Setting up your UPS

	Chapter 7. Configuring your Internet Connection
	7.1. Network and Internet Connection Management
	7.1.1. Set Up a New Network Interface
	7.1.1.1. Wired Ethernet Connection
	7.1.1.2. Wireless Connection
	7.1.1.3. ISDN Connection
	7.1.1.4. Modem Connection (POTS)
	7.1.1.5. DVB Connection
	7.1.1.6. GPRS/Edge/3G

	7.1.2. Internet Settings
	7.1.3. Reconfigure Interfaces
	7.1.4. Monitoring Connections
	7.1.5. Removing a Connection
	7.1.6. Proxy Settings

	7.2. Activating and Managing Network Profiles
	7.2.1. Profile Handling

	7.3. Wireless Connections Management (Roaming)
	7.3.1. Switching Networks
	7.3.2. Configuring a Wireless Connection


	Chapter 8. Managing your Users, Menus and Services
	8.1. Configuring StartUp Services
	8.2. Managing Fonts on your System with DrakFont
	8.3. Setting your Machine's Date and Time
	8.4. Monitoring System Activity and Status
	8.4.1. Browsing System Logs

	8.5. Managing Users and Groups
	8.5.1. The Interface
	8.5.2. Adding a New User

	8.6. Backing Up and Restoring your Files
	8.6.1. A Practical Example Using the Wizard
	8.6.1.1. First Step: What to Backup
	8.6.1.2. Second Step: Where to Store the Backup
	8.6.1.3. Third Step: Review and Store the Configuration
	8.6.1.4. Performing the Backup

	8.6.2. Restoring Backups
	8.6.3. Automating Periodic Backups
	8.6.4. Advanced Backup Wizard Configuration


	Chapter 9. Securing your System
	9.1. Securing your Internet Access via DrakFirewall
	9.1.1. Choose Services to be Available from Outside
	9.1.2. Activate Interactive Firewall Feature
	9.1.3. Which Interface to Protect


	Chapter 10. Mandriva Online Services
	10.1. Initial Configuration
	10.2. The Web Management Interface
	10.2.1. Subscribing New Machines
	10.2.2. Host Management
	10.2.3. Scheduling Updates

	10.3. Mandriva Online Applet


